Questions & Answers

Working with studio live 16.0.2 and MAC OS Catalina

0 votes
737 views
asked May 26, 2020 in Classic Mixers by krissmets (200 points)
Hi,

yesterday I upgraded my Macbook Pro from OS High Sierra 10.13.6 tot OS Catalina 10.15.  After I downloaded and installed the Presonus install package (Fire Wire Drivers and Installer UC) my Macbook kept not recognizing my Presonus 16.0.2 (connected with firewire to thunderbolt) and I wasn't able to use it anymore as a speaker or an audio device in my DAW (Logic).  Today, I was forced to go back to my backup and OS High Sierra again, now everything operates just fine as before.  

Can you please confirm that when installing UC 3.2.1. (the driver of 14/4/2020) this should work with OS Catalina ?  And is it recommended to install the fire wire drivers first and then the installer UC ?

Many thanks in advance for your answer,

Kind regards,

Kris

4 Answers

0 votes
answered May 28, 2020 by jonnydoyle (383,990 points)
 
Best answer
You need to install the firewire drivers from the downloaded file.
asked May 29, 2020 in Classic Mixers by krissmets (200 points) That's what I did
0 votes
answered May 31, 2020 by chrislovell1 (360 points)
I've had the same issue. Installed the firewire drivers with UC3 package, and still not working as an audio interface. Please help!
0 votes
answered May 31, 2020 by chrislovell1 (360 points)

UPDATE: I got my 16.0.2 working as a 16in/16out audio interface over firewire on Catalina. Turns out, during the installation of the firewire drivers, apple's new security features disable the drivers on installation, with no warning!? 

You'll know if this is the case if you follow these instructions:

https://support.presonus.com/hc/en-us/articles/210047233-How-Do-I-know-my-StudioLive-is-connected-to-my-computer-and-functioning-over-firewire-

Also, if you check on your StudioLive 16.0.2 firewire mixer System Menu >> "Page 3: Digital" the status will say "no driver" if the driver has been disabled.

To check for disabled software, follow this answer (it says OS X 10.13, but works for 10.15):

https://answers.presonus.com/27478/installed-universal-control-system-firewire-devices-showing?show=27480#a27480

To rectify, follow these instructions (again, it says OS X 10.13, but works for 10.15):

https://support.presonus.com/hc/en-us/articles/115005456483-Installation-Issues-with-Universal-Control-on-High-Sierra-Mac-OSX-10-13

Won't get UC working, but will get your mixer taking to your computer. Hope this helps!

0 votes
answered Feb 17 by ojplbvgd (140 points)
Hi,

I had the same issue with my Mac mini 2012 on Catalina and Presonus 16.0.2 (connected with firewire to thunderbolt). After installation, the mixer will show up to be connected by FireWire, but the drivers in disable software. After hours of reading and trying, I founded a way which worked for me, and might work for others:

1) If you had previously installed any of the drivers or controllers, uninstall everything with the Presonus hardware uninstaller tool (in the .dmg file)

2) Restart your computer

3) Install Presonus universal controller

4) Go to Security settings and allow the driver, close settings

5) Install Presonus FireWire Driver

6) Go again to Security settings and allow the driver

7) Plug in and turn on the Mixer, launch the program and it works! (at least for me)

Enjoy fellows, courtesy of my wife, she was the one who fixed it ;)
...