Questions & Answers

Resident audio T4 interface won’t run on OS Catalina.

0 votes
2,897 views
asked May 30, 2020 in Studio One 4 by michealgoldsworthy (120 points)
I have just installed studio one Pro, bought an interface (Resident Audio T4 Thunderbolt) running MacBook Pro i7 2.8ghz 16 gig ram. The OS is Catalina 10.15 what I have just discovered is the T4 driver won’t run on OS 10.15 but will run on earlier versions up to OS 10.14 so I have the option of running my MacBook using say OS 10.14 as I have only just purchased it and the only software I have set up on it is Studio One. But what I am worried about is if I update the OS to 10.14 will I loose my software download to this MacBook meaning my count will be 2/5 available platform downloads or will it stay as 1/5 as it’s the same Mac but a different OS. Can I just do a back up onto my secondary HD of my studio one software and then pull it back out after the downgrade to earlier OS version? I am fairly new to using Mac and first time user of any DAW. Very frustrated by this situation and am a layman when it comes to computers. My other option is sell the T4 interface and just get a compatible one. I thought perhaps there was a way to still use the T4 but the Mac doesn’t recognise it so no luck whatsoever.

1 Answer

0 votes
answered Nov 21, 2020 by nolantunnicliffe (140 points)
edited Nov 29, 2020 by nolantunnicliffe

This has worked on my macOS Big Sur. I upgraded by transferring my data to a new MacBook Pro. Then my interface stopped working for an unstated reason.

The problem with the RA T4 is that the installer checks for a known version of the OS and fails on Catalina and above. But we can extract the components of the installer and install them manually.

Download the https://macpaw.com/the-unarchiver . Install it.

Download the latest driver for T4 or T2 from ResidentAudio.com.

Unpackage the contents of the T4 driver by right clicking in the Finder and selecting, using Open With->The Unarchiver. Do this to all the contents the first layer does and so forth on the second layer, recursive.

When thats finished:

Open the Scripts folder and its two files 'preinstall' and 'post install' . I think best to not run the preinstall as it mainly deletes previous installation.

Use the 'content' of the uninstall script below to copy the contents to the correct folders:

"

KEXT="/Library/Extensions/ThunderboltT4AudioDriver.kext"

BUNDLE="/Library/Extensions/ThunderboltT4AudioPlugin.bundle"

MIDI="/Library/Audio/MIDI Drivers/ThunderboltT4MidiDriver.plugin"

APP="/Applications/ThunderboltT4 Panel.app"

OLDKEXT="/System/Library/Extensions/ThunderboltT4AudioDriver.kext"

AggeUID="net_egosys_driver_ThunderboltT4AudioEngine:InOut"

Domain="/Library/Preferences/Audio/com.apple.audio.SystemSettings.plist"

"

That last two lines, I don't understand but it worked for me without it.

Open the Scripts folder and its two files 'preinstall' and 'post install' , open a terminal and prefix 'sudo' then drag the 'postinstall' in the Terminal to get the path and file to appear after your typed sudo. Press return and type the password.

My mac required a restart before it worked. It doesn't seem to work with hot swap without a restart. I have a StarTech TB3 to TB Adaptor and would be interested in whether a Apple TB3toTB adaptor works with hot swap or what is required to get hot swap going.


If you ended up buying a new audio interface, learn how to use Multiple Audio Interfaces - Aggregate Device in OSX

...