Questions & Answers

No power for my brand new E3.5

+2 votes
7,326 views
asked Jul 14, 2020 in Sceptre, Eris, R-Series by balinstrand (140 points)
I just received my E3.5 monitors today, and I have everything set up and plugged in, and I have checked that my power strip and outlet are all good and they are, but when I flip on my master power the blue pilot light doesn't even come on and I can't figure out why, and the manual is absolutely no help. Is there anyone else that's had this issue? And how did you fix it?

7 Answers

0 votes
answered Jul 15, 2020 by geraldbritton (2,190 points)
Sounds like a mfg defect.  You might have to return them.  have you tried them in another room?
+1 vote
answered Jul 18, 2020 by jamesdiaper (160 points)
I'm in the exact same situation. No power at all to my brand new E3.5. literally just opened them out of the box
+1 vote
answered Sep 30, 2020 by ralphtaylor1 (160 points)
Hi, I have just experienced the same thing.  They worked once then stopped. I tracked the problem down to a blown fuse in the plug. I determined that this happens when the unit is switched on.  I tested by putting a new fuse in and checking the voltage using a multimeter where I was getting 232 volts across the two pin terminals on the lead.  I switched off at the mains and plugged the cable into the speaker, switched on at the mains but did not switch on at the speaker. I then removed the power cable from the back of the speaker and tested the terminals again, getting 232 v as before. I then plugged the power cable back  the speaker, switched on at the mains, then switched on at the speaker. No blue power light! I removed the power cable from the speaker and tested the terminals again.No voltage registered.  I can only assume that when you switch power on at the speaker it's shorting out an blowing the fuse in the plug. The fuse is 3 amp I wonder if that is too low but don't want to try just in case.  I'm posting a ticket with these details.
0 votes
answered Sep 11, 2021 by mohamedlahmar (140 points)
Hello, I have just experienced the same thing ! very frustrating when this happens as you unbox the thing. Did you return them ?
0 votes
answered Oct 25, 2021 by tobymoore (140 points)
I received the E3.5 monitors in the mail today. No power straight from the box. Mostly from frustration (but also a desperate determination to try anything) I slammed the plugged-in master speaker onto my lap. Unbelievably, the little blue light came on and I had power and sound.

Surely they must pass a quality check before packaging. Could something have come loose during shipping? Not knowing much about circuit boards & electronics in general, my accidental fix makes zero sense to me. But hopefully my experience sheds some light on present & future problems such as this one.
+1 vote
answered May 13, 2023 by pachoshvilizurab (160 points)
@Hi here,

has anyone found out the solution?

Im facing the same issue:  all of sudden, monitor is not turning on.

Previously I had a case when it turned on with some minutes delay.
0 votes
answered Sep 25, 2023 by paul.roberts2166 (140 points)
Hi i have the same problem with my E3.5 BT, which I have just brought use it twice and now no power, its disappointing that so many people have complained about this similar problem, which appears to be a manufacturing problem on the power switch, it a waste of money and when trying to submit a ticket, it states that I need to activate even when I have registered.

if anyone can help please let me know

very very disappointing, I would never recommend it to anyone
...