Questions & Answers

Studio One 5 Undo stops working BUG!

+21 votes
asked Jul 26, 2020 in Studio One 5 by romaindescampe (3,670 points)
I've noticed now on two separate occasions that the Undo (CMD-Z) function stops working all of a sudden in the middle of a session. I cannot use Undo from the "Edit" dropdown menu either, but can use the Undo history window to go back to a previous point.

This problem persists even if I close the session and/or the program. I also tried to disable/enable the undo option in the Console configuration preferences, but nothing changes.

When this happened the second time, I loaded an autosave from 5 minutes earlier, and there undo is still working completely as it should. Very strange bug. Please let me know if anyone has managed to fix it as it has already broken one of my sessions entirely.

And a bugfix in the next version of Studio One 5 would be much appreciated!!

17 Answers

+2 votes
answered Jul 26, 2020 by romaindescampe (3,670 points)
I just noticed this bug happens when I add an instance of Antares Harmony Engine. Not sure this was the issue in my previous session as well, but clearly it seems plugin compatibility might be a factor.
+4 votes
answered Jul 30, 2020 by rionquiroz1 (4,270 points)
in your settings advanced console clicking the enable undo option worked wonders for me i guess presonus stops it just incase your undoing something like a plugin that setting should fix the issue tho it at least worked for me! hope this helps man
0 votes
answered Aug 2, 2020 by element-92 (160 points)
I JUST upgraded to S1.

Half of my plugi-ins are black and CMD Z didn't work from the get-go....

Which is an option I use every 10 seconds...

It works IN plug-ins not in de DAW.

I tried enabling/disabling and enabling the undo button in the advanced tab but to no avail...
0 votes
answered Aug 31, 2020 by estudiomub (610 points)
Happening to me as well, really annoying. I'm trying hard to move from PT to S1 but it's kinda of a pain...
0 votes
answered Sep 14, 2020 by georgeheredia (240 points)
edited Sep 15, 2020 by georgeheredia
This is happening to me all of a sudden.  Presonus, this is a deal breaker as I do A LOT of cut and paste and undo.  Come on.  Fix this already.

EDIT:  not sure if it is plugin incompatible.  Pretty much only using THU guitar plugins so far, and has not been an issue when starting a new song.  

That said, I am thinking this is more about importing stems and midi from a project started in Logic Pro X into Studio 5, as this is the first project in Studio 5 that I bring in stems rather than start a new project from scratch.  This would defeat the purpose of having Studio 5 since it would not really let you bring in other projects to mix and master.
+1 vote
answered Sep 20, 2020 by adarshchandran (5,420 points)
Oh. My. God. The undo bug drives me NUTS.
It happened especially when I was editing audio and maybe even melodyne. It bugs for a particular save session. If I make a new session it works fine. But it. Has. To. Be. Fixed. Immediately. Presonus please!
+2 votes
answered Sep 27, 2020 by roba4 (320 points)
My dudes...this bug S U C K S. Sitting here thinking WTF do i do right now? How is this even a thing?


So it gets to 1000 undos and locks up. Hit Edit > History on the DAW menu screen and you can click back through. But wow, what a pita.
+1 vote
answered Nov 2, 2020 by tothrec (31,840 points)
The suggestion to check "enable undo" did not work for me as it is already checked.

Come on, Presonus.  This is a big one.  Please fix ASAP.

+1 vote
answered Nov 5, 2020 by adarshchandran (5,420 points)
edited Nov 5, 2020 by adarshchandran
OMG.... The undo glitch drives me nuts. Please please please PRESONUS. FIX THE UNDO GLITCH ASAP. Still not fixed in 5.1 update!!
0 votes
answered Dec 3, 2020 by rubenmorales1 (550 points)
This happens to me when I move audio files from Logic Pro X to S1. The whole session is corrupt, even when I open a new session and import the data from the previous session. The undo bug transfer to the new session. This is really frustrating I already made like 6 sessions of the same song in hopes I the undo will work.. Presonus please FIX this.
0 votes
answered Jan 7, 2021 by eighthlight (380 points)

 rionquiroz1 Thanks for your help. You were RIGHT.  I went to Preferences> Advanced>Console and I UNCHECKED "Enable Undo" . Now Its Working Perfectly!!!!!! BTW I suggest Everyone Look into th ATOM SQ. Pretty Nifty controller if you dont want the faderport.

0 votes
answered Apr 25, 2021 by miguelbernardo1 (140 points)
Hey guys, i am having the same issue on studio one 5.2.0 the last update.. Is there any solution? Tried the advanced console settings  and did not solve it.. Even restarting the program could not fix it on the project.
0 votes
answered Aug 21, 2021 by johnkleist (140 points)
So as odd as it is, I checked if the “enable undo” box was checked under the advanced settings (console) and of course it was and still the undo button would not work (nor my favourite hot key “Ctrl. Z”), so this time I unchecked the enable undo box…and what do you know…now it ****** works!  Makes no sense, but I am happy.
0 votes
answered Aug 30, 2021 by mauriziobaggio (1,110 points)
edited Aug 30, 2021 by mauriziobaggio
Bought presonus sphere a week ago

I started using S1 5.3 this very morning to mix a song, super excited!

encountered this bug right away! I can undo using the menu command or history...the key command doesn't work

I'm unbelievably sad :(

UPDATE: I found out that LOW CONTROL plug in by Black salt audio is causing this bug, only the AU version though not the VST....
0 votes
answered Sep 6, 2021 by georgenext (8,650 points)
So annoying after all this updates, this bug as a few more are still here. I hope Presonus, will make a bold move for professionals and make S1 robust, they should put a lot of focus and effort to make S1 move on top of the chain on DAWs stability. I still hope they are listening and take some aggressive action against the few flaws this otherwise perfect DAW.
0 votes
answered Oct 2, 2021 by Inthesilence (140 points)
I just experienced this...with the update to Studio One 5.4!  So they didn't fix it. It never happened to me on previous versions. I also just installed a FaderPort, I don't know if that triggered the bug. I hope someone can fix this, it basically makes my workflow impossible.
0 votes
answered Mar 31, 2022 by dmitriyprotopopov (140 points)
I deactivated "Enable Undo", and all works :)