Questions & Answers

FaderPort 8 Motorised faders dead

0 votes
66 views
asked Oct 9, 2020 in FaderPort 8 by michael-rosshillman1 (200 points)
Hi All

I hope you are all well and in good health.

I am absolutely devastated, the centerpiece to my studio, the FaderPort 8 has packed in after updating the firmware to 3.4.3.

I have opened up a ticket but just wanted to see if anyone out there may have found a fix.

The issue

After using Universal Control to update the firmware the motorized faders died, all other functions appear to be working well.

I went into the device setup on the unit and ran some tests(Select buttons + Power), all the tests pass, but the faders are not being detected in the "test inputs" section showing "not touched". In addition, the mardi gras mode is not moving the faders when engaged

I reset the device to factory settings which took the firmware all the way back to v1.01. I then opened up UC and tried to update the firmware again and still the same scenario with the faders.

I am using the supplied 12V 2A power supply and have tried another one with no joy. I have tried disconnecting all other USB devices to run the firmware updater again, using a variety of USB cables and ports on my computer. I have used another PC to see if the PC may be the issue.

Please help with any information you can, I am desperate to get up and running again.

Cheers

Michael

2 Answers

0 votes
answered Nov 22, 2020 by ujgbtapm (140 points)
Have you found a solution to this problem friend? I have the same situation
0 votes
answered Nov 23, 2020 by michael-rosshillman1 (200 points)
Hello,

I contacted Tech support and they took it in for repair. It looks as if the firmware update killed half of the faders and the whole fader unit was replaced.

Annoying and expensive problem to fix!

Best of luck with it all!

Michael
...