Questions & Answers

Faderport 16 - faders suddenly not working & firmware update fails

+1 vote
92 views
asked Jan 10 in FaderPort 16 by fredericsellmeier (130 points)
edited Jan 10 by fredericsellmeier
EDIT: I just can't sit still with these things. After finding another thread with a simlar problem on a Faderport 8, I went ahead and uninstalled Universal Control and restarted my system. I then downloaded the latest UC version from the Presonus site and installed it. Lo and behold after that, the Faderport suddenly showed up with Firmware version 3.21! I then went ahead and started the update procedure which was 3.21 --> 3.32 --> 3.44 and that worked! Faderport 16 now works fine again and I've no problems.

The core issue seems to be that an update from 3.43 to 3.44 is not possible, but 3.44 is required now for everything to work properly (which is only stated on the product page under registered products :-/).

Hi!

Up until today, my Faderport 16 (Firmware Version 3.43) worked without any problems.

Turned on my Laptop today, turned on the Faderport, started Studio One 5, opened a song and nothing happend, the faders didn't move into positoon as they should. Controls such as play/stop work, but nothing else, also the small LCDs at the top of the Faderport are empty as soon as SO5 is opened.

Started Universal Control (running on Windows 10, 2004, 19041.685) to check and saw there was an update to Firmware version 3.44, so I thought maybe there's a connection and I need to update. Tried updating, however during the update, the LCDs show 0% complete the entire time. Universal Control tells me the update was successful after about 5 minutes, but the Faderport itself shows the update failed status in the LCDs and all select buttons blink red.

Cycling the power and trying different USB ports does nothing, still have the same problem. Entered the Faderport 16 setup and checked the functionality using the Mardi Gras test and everything works fine, faders do their sinus curve thing, all buttons blink in different colors. Tried a factory reset after that, but nothing changes - still no reaction from the faders in SO5.

If I go into a song and then into the SO5 options and select to "reconnect" the Faderport 16, the faders work, albeit only with massive delay. This is not an option.

The setup of my system has not changed since the last use of SO5 where the Faderport 16 still worked fine. No OS updates, no DAW updates, nothing. Any idea what else I could try? I've had the Faderport for only 6 months, I'm kind of disappointed that I'm running into issues this soon.

Cheers,

Fred

1 Answer

0 votes
answered Jan 23 by salvadorgarcia4 (150 points)
Hello I also have this issue with the faders, just got my Fadeport 16 and it seems like the faders are you could say "jumpy", not writing automation correctly, so when I move a fader in the Fadeport it doesn't move in Studio One.
I started using it a couple of days ago so just downloaded everything and it seems to be up to date, lets hope they come up with a solution, otherwise I'm gonna have to return it, I really liked it though.
...