Questions & Answers

Faderport 16 display won't light up when session opened, refuses to update firmware

0 votes
96 views
asked Feb 18 in FaderPort 16 by jplatinum (280 points)
Computer still recognizes and communicates with Faderport, but the faders won't go up whenever I start a new session. Tried updating the firmware through Universal Control, keeps telling me to power cycle the device while the Faderport itself is stuck on "Please wait..." and never goes past 1%, which means my only option is to restart it and begin the cycle again. Both soft and hard reboots have been tried to no avail. I've had a similar problem before, but my previous solutions didn't work.

2 Answers

0 votes
answered Feb 20 by nickmaggio (23,070 points)
 
Best answer
You may want to reach out to Tech Support in this regard.
0 votes
answered Sep 14 by nige108 (230 points)
Hi there,

I'm just wondering whether you got this sorted? I have managed to get the firmware to update by using another PC to do so. God knows why you should have to do that but anyway, upon reconnecting back to my regular PC the problem still exists. The lights wont light up on the buttons when pressed, most of the buttons do nothing and the faders do not update when opening a new song and the scribble strips the same.

Any tips would be appreciated. By the way. Running W10 64 and S1 pro 4. No changes have been made to my system lately. This is literally working one day, next day not. W10 updates are disabled.

Thank you
...