Questions & Answers

Installed new driver and still not working. Macbook M1 and Quantum 2626.

+3 votes
asked Mar 24, 2021 in Thunderbolt - Quantum by dannyguerrero2 (310 points)
I was happy to see the driver update. Went ahead and installed but no luck. I am still showing a blinking light and interface does not show up. Anyone having the same issues or figure out a way to make it work? Help!!!

13 Answers

+2 votes
answered Mar 24, 2021 by scottwelch1 (180 points)
Same issue with non M1 Mini. Did the install today and now UC can see my Quantum but now OS can not see it; but it works fine on my MacBook Pro after doing the same update.
+1 vote
answered Mar 25, 2021 by davidhalton (160 points)
Same problem here, most frustrating interface ever.
0 votes
answered Mar 25, 2021 by cordeirocla (180 points)
Same issue here! Tried the install several times but the latest Universal driver still does not work on the M1 mini Mac.
0 votes
answered Mar 25, 2021 by martythorne (210 points)
Same here. Completely uninstalled/reinstalled about a dozen times, checking all cables and hardware in the process. Got my hopes up this time. No noticeable differences from previous attempts.
0 votes
answered Mar 26, 2021 by dannyguerrero2 (310 points)
This completely blows. My system has been bricked for almost 4 months. I once, again set up a support ticket and I get the same response.

" Please send me your computer's System Profile so that we may verify connectivity and installation."

This is the same reply I received 4 months ago when I first had issues with the system. I called their office and they don't offer any technical support over the phone but I wads assured my issue would be "expedited".

It seems like Presonus has one guy "Butch" handling all tech support tickets. Come on guys you need a better support system.I have been working in the MI industry for over 10 years and this is the worse support I have ever received. I am on the verge of selling this interface and never buying anything Presonus again.
0 votes
answered Mar 26, 2021 by petrbajer1 (180 points)
I re-installed UniversalControl (using unistaller) about three times on my Macbook Air M1 and blue light keeps blinking. Presonus dont take care about support too much (except very slow bot-like communication as you describe here) because they know that there are no other options on the market. Even UAD does not declare full support to M1. Or do you know about something?
+1 vote
answered Apr 1, 2021 by derekrickett (160 points)
Focusrite works great on M1.  Mine does anyway.  My quantum is blinking blue and red.  It connected for about 30 seconds and hasn't connected since.  I have send my system files twice now and contacted apple.  I don't think this driver of theirs works.  I have not seen a single person say it actually works.  Obviously the update is junk.  I guess i'll just stick to focusrite.  At least their stuff works and you can get the support you need with a real person unlike presonus.
+2 votes
answered Apr 1, 2021 by dannyguerrero2 (310 points)

I finally got my system up and running. I think we just dont have enough information on the release notes to get this to work.

I keep unistalling and installing the driver but no work.I was actually a key piece of information.

this is the information I received from tech support.

" Download the current version of Universal Control.

Run the Uninstaller first.

When complete, restart the computer.

Then run the UC 3.4.2 Installer.

When complete, navigate to System Preferences and open the Security & Privacy settings.  Allow the Quantum driver extensions if available.  If not, disregard.

Restart the computer again."

My privacy settings were not allowing for the quantum driver extensions to work. I had to go into the privacy settings and turn that on.

Once, I did that then it worked and has been working flawlessly.

0 votes
answered Apr 2, 2021 by ianwidgery (1,030 points)
Having the same problem here. Big Sur M1.

I got it working for 2 days and then added a spdif connection and the whole thing stopped working. I think its a clock issue with the 2626.

BLINKING BLUE / RED. 3 Fresh installs of os and still not working. 60 Hours this week on this.
0 votes
answered Apr 10, 2021 by jasonyost1 (140 points)
Just made the mistake of updating the driver for my Quantum 2626. Now Logic Pro X on my MacBook Pro 16 will not recognize the Quantum.....great.
0 votes
answered Apr 15, 2021 by hrtyklfh (140 points)
I was able to get up and running on M1 using the security hold button reset instructions, but now my 2626 keeps disconnecting from Logic for no reason. It's happened 3 times in a hour session today, I had to hard reboot to reconnect> Is this happening to anyone else?
0 votes
answered May 2, 2021 by pbwlmlnu (280 points)
edited May 3, 2021 by pbwlmlnu
hrtyklfh, its the same for me. I managed to enable the kernel extension through the recovery mode, but after that I either have it working for a couple of dozens of minutes, or it starts to act crazy and disconnect within a minute after reconnection, playing high pitch sound as it disconnects. Support just ask me to send the System Profile and suggesting to reinstall the latest driver. They asked for a video about the high pitch sound, then sent me a readme about white noise. I have the latest drive. I reinstalled it more than 20 times. I disabled SIP just to make sure its not a security issue. I was almost returning the device when I found this thread, but it made me hope its going to work at some point, which I can wait for. I hope its sooner than later.

First PreSonus product I have, not sure what to think.

BTW, it works fine with MBP i7 + Catalina.
0 votes
answered May 7, 2022 by mqckhrad (140 points)
Experienced issues as well but I think I have them resolved. Setting up a new quantum 4848 and Mac Studio with M1 max, Ableton. Blinking light issue was resolved by going to settings then Security and Privacy / microphone / then allowing Universal Control and Ableton. Then my thunderbolt light stopped blinking. Ableton daw still wouldn't allow me to choose quantum as my audio device, until I made sure that my external word clock was set up properly. If you're using the internal word clock setting in Universal Control you should be okay, but if you're trying to use external clock and quantum isn't receiving the signal properly (settings on master clock are off, not sending) then Ableton will not let you choose quantum as your audio source. Check privacy settings, and make sure clock is set up right. Worked for me, good luck.