Questions & Answers

Why won't the latest Universal Control + Quantum 2 work with Intel Macs on Big Sur 11.4?

+2 votes
1,214 views
asked Jun 11, 2021 in Thunderbolt - Quantum by dolphinmichelini (250 points)

Here is was what happened: 

I installed the latest version, PreSonus_UniversalControl_v3_5_0_64605, onto Big Sur 11.4 Intel, and it worked, until that is I restart my computer. After that, the Thunderbolt indicator light flashed blue and the power button was a solid red. I tried everything that Presonus recommended, including all the security measures and re-installing.

I even reduced the startup system security to medium in recovery mode, hoping that it would allow the kernel extensions to work properly. No good.

Here's how I fixed it:

Just as user ianlehmann recommended, I uninstalled the latest version, restart the Mac, then installed an older version of Universal Control, and finally restart again, and it worked!

I specifically went back to PreSonus_UniversalControl_v3_4_2_63992 from March 2021.

Please log in or register to answer this question.

...