Questions & Answers

Loom 2 and Hybrid 3 PlugIn for Studio One Artist?

–1 vote
264 views
asked Jun 21, 2021 in PreSonus Hub / Plugins by bjornciggaar (110 points)
Hi,

I had just bought a package of three ADSR plugins; Loom 2, Hybrid 3 and The Riser.

However I only got the Riser to show up in my Studio One Artist. ADSR informs me the plugins only work for Artist (or I need to download the ReWire). But... It might work if The Riser did work. So I'm kind of confused if this is a definite yes or no. I also made the mistake of not using iLok and skipping the Loom 2 and Hybrid 3 registration the first time I started up Studio One Artist (because at that time it did recognise the plugins and asked for a registration code). Realising I should've registrated at start I did enter the registration code for The Riser and now that's the only one visible so far.

Tried removing, re-installing... iLok shows I have succesfully registered. And the plugins are in the correct folder.

Any help is appreciated, because I like to know for sure before I upgrade or purchase any other software to make this work (an Upgrade to Artist had been on my mind, but I am doubting if I would make much use of the extra's that come with it).

Thanks!

Bjorn

2 Answers

0 votes
answered Jul 27, 2021 by jasoncollins (660 points)
Hi Bjorn

Did you manage to resolve this? I'm also having the same issue with Loom 2 on a new(ish) Windows 10 build (last December); but I'm running the latest install of Studio One 5 Pro and been using the latest install version of Loom 2. Loom 1 isn't even showing.

I've tried to uninstall and reinstall over several weeks with no joy i.e. Loom is not showing in list or in plug-in manager.

This is the only plugin I'm having issues with.
0 votes
answered Sep 19, 2021 by jasoncollins (660 points)
Hi Bjorn

I've manged to resolve this same issue, finally, after installing v5.4 Pro. Going into the new Plug-In Manager, it asked me to reset my plugin settings and restart Studio One. After I did, after many months, Loom 2 was finally showing. To note: When ever I start Studio One it is set to scan for plugins, but never picked up Loom until now.

I hope this helps.
...