Questions & Answers

Audiobox USB 96 input 2 not working

0 votes
139 views
asked Jul 17 in AudioBox USB by davidwong3 (120 points)
I know this question has been asked before but I don't see any answers that sort me out unfortunately.

Now I'll admit, I'm a complete noob with this.

I bought the Audiobox USB 96 + SM58 approx 3 years ago... and before I got to really delve into it I got extremely sick and I haven't picked it back up until today... so I can't even remember if it all worked back then or not, I just know I had trouble with how "quiet" my recording was... but I will mention that later.

My input 1 works a treat - no issues. But input 2 seems to be busted, I have troubleshooted by switching mics (both the one that came with the set + SM58) from 1 to 2, and then switching cables etc. . . everything worked with Input 1 but not 2. In addition, even when I was plugging things into the 2, it made NO popping sound at all. None. Nada. But if i turn the dial up... you get the noise from the system, but still nothing from the mic itself.

On that note... back to the "quiet" situation. So, i basically have to dial the mic to 60 (+30) for a decent sound to be recorded. Anything less and whilst the playback is great, the actual recording comes out as a whisper. But when I put it at that maximum... unfortunately noise starts appearing in the recording :( oh and! I know the light of the clip is meant to light up... but i can almost never get there...unless tapping on the mic itself.

I've just someone who enjoys singing...and decided to splurge many years ago, and this is really sad :(

ANyone with any idea, if you can speak up that would be great

Please log in or register to answer this question.

...