Questions & Answers

Can I connect a PreSonus Firewire interface to an iMac and use the interface with Logic Pro?

0 votes
1,572 views
asked Jun 30, 2022 in FireStudio Series by needhelp (120 points)

Hello,

I have an  iMac 2019 version 12.4 macOS Monterey   and    the PreSonus Digital Audio Firepod. I am trying to use this interface to record as many mic lines as it will take, but I can't get it to work.... iMac says USB connectivity is too high everytime I plug it via firewire to USB-A adaptor.  This might be a very simple solution in that this interface may just not work with iMac.  But I'm wondering if I can connect via firewire adaptor to a USB-A? (My iMac only has USB-A).  

And if that doesn't work, does anyone have any suggestions as to how I can put this large interface to use? It has so many line-in's and for a great price, I am trying really hard not to buy a different interface seeing as I already have an Apollo twin for smaller projects. Thank you so much in advance!

**not sure if this is also important to note but I only have Logic Pro for a DAW

1 Answer

0 votes
answered Jul 18, 2022 by davecollins (190 points)
edited Jul 19, 2022 by davecollins

Hi There,

USB-to-Firewire adapter do not work and never have worked, as they are completely different protocols. Not sure why scammers are still selling these useless adapters. You will need a Thunderbolt 3 to Firewire adapter (https://www.apple.com/ca/shop/product/MD464LL/A/apple-thunderbolt-to-firewire-adapter) and a Firewire 400 to 800 cable. You can download the firewire driver from the Firebox support page (https://www.presonus.com/products/FireBox/downloads), but you might also want to try the latest firewire driver which can be found inside the installer DMG of any newer interface support page.

That said... I have been running a Firestudio 2626 and Firestudio Lightpipe for years but when I updated to macOS 12.3 they stopped working. Universal Control v1.7.6 (which is the last to work with the 2626) stopped working in macOS 10.14 or 10.15 (can't remember exactly when) but the interfaces still worked perfectly fine. They are now seen by macOS System Profiler but do not appear as audio interfaces. macOS 12.4 was supposed to fix firewire issues but it hasn't fixed things for me. Hopefully a future update will restore functionality. Others have reported Firewire functionality was restored with 12.4, so I can't say whether or not it'll work for you.

Hope that helps.

UPDATE: Last night I updated OpenCore Legacy Patcher to v0.4.8 (I'm running macOS 12.4 on a 2012 13" MacBook Pro) and did a fresh Build and Install OpenCore. After a restart, Post Install Root Patch, and PRAM Reset, both Firestudios are working again! I still need to connect them to my 2008 MacBook Pro to make changes to the I/O / monitor / clock setup, but the changes hold when connected to the newer laptop.

...