Questions & Answers

major cpu spikes in studio one 3 during playback

+6 votes
708 views
asked Aug 2, 2016 in Studio One 3 by AYODJELI (650 points)
  • late 2015 IMac 27 5k retina 1gb flash 40 gb ram
  • osx El Capitan 10.11.6
  • Studio One 3 (3.2.3)
  • Focusrite Clarett 2 pre
Hey hows it going, I just bought S13 pro the other day and noticed constant cpu spikes that distorts the audio during playback. I use the same pref setting as i do in both logic and ableton (buffer size set to 64 and all cores checked) without issue so I know my computer can handle it but in studio one I'm getting major spikes. Any other reason why this may be happening or have any suggestions on setting my prefs for optimal performance without spikes?  
Thank you,
ELi

4 Answers

+3 votes
answered Aug 2, 2016 by ryanmiller13 (18,110 points)
 
Best answer
While your computer has outstanding specs, you might need to raise your buffer size to get rid of the CPU spikes.
+1 vote
answered Sep 13, 2017 by randallroop (160 points)
I had my CPU SPIKING   making all sorts of popping and crackling ,  looked at youtube for hrs. with no help,  all people were talking about was the audio device settings.  That didn't help.  My friend told me about the UNIVERSAL CONTROL (  Hardware )  window ,  this section was not in the studio one main page,  it was in the SHOW HIDDEN ICON  section on the main computer screen.   There  I found  the SAMPLE RATE,   CLOCK SOURCE,  BLOCK SIZE,  INPUT FORMAT,  OUTPUT FORMAT.  Once I changed the   BLOCK SIZE   the CPU went back to normal !!!!!

I know I just read about the buffer size, but a little plain talk there would help.  Please show this answer, I am sure someone needs to know this.     Thanks Presonus.   Randall Roop
+1 vote
answered Sep 16, 2017 by joshuasmith5 (210 points)
I was going through that. As of now whats worked for me was i use a windows laptop.

i had to change my power plan in power settings to high performance. and simple as that it was fixed.

i think when my computer updated it changed to power saving at some point.

but if anyone else on here is looking i got the idea from a no more glitch pdf by robert... i dont remember the name fully. its for windows

in nature but i think macs can apply the same ideas.

so if all your settings, buffer, and sample sizes are all good in studio one, it may be the computer power settings.
0 votes
answered Jan 6 by peterulbig (160 points)
I had the same problems (using an I7 5820 6 core, 16 GB RAM, only SSD and M.2). Studio one indicated a Performance load of about 80 to 90 %, while the task manager showed a CPU load of each core of about 8 to 12 %. I use East West Hollywood Orchestra and several vst plugins (especially 4 instances of algorithmic reverb, WAVES Aphex Exciter, WAVES Bass enhancer, sonible frei.raum EQ).

What helped were finally two things: disabling the turbo boost of the processor in the BIOS (helped a little, but not sufficient) and to change the power management in Win10 to "high performance" (and no balanced mode of energy saving and performance).

Now the Performance indication in Studio one is in the range of 50 to 70 % (using all the mentioned plugins simultaneously!) and the CPU load of each core is about 30 to 50 %. So there is still much reserve to have more plugins.
...