Questions & Answers

Firestudio Project: Driver not able to run (error code: 52) Windows 10

+1 vote
938 views
asked Nov 30, 2016 in FireStudio Series by doktorfaustus (160 points)

Hello!

Our system has a FW-card w/ a chipset from TI. (PE-101 from Lycom)

Short recap after 4 hours of frustrating troubleshooting:

Able to install driver via both UC 1.7.2 & 1.7.4, but they do not run due to not being signed (Code 52).

After disabling 'Secure Boot' in the UEFI, I managed to run the drivers and getting sync (or so the status light tells me).
I got the drivers to run, and getting an indication of sync, but we had no sound.

The cable is not the problem, because we have been using it on our previous machine without problem.

We're unable to get a hold of Windows 7 and the interface works on my Mac-computer.

What am I supposed to do to get this working?

I've tried reinstalling both drivers, universal control and clearing the folders after uninstall.
Also deleted PaeFirestudio*.sys-files in System32\Drivers folder.

I can't explain my frustration, but believe me - we need to get this working.

I found an article here about using a Beta release of UC 1.8.2 which should've had updated signing for the drivers, but that post wasn't available.

Please help me!

1 Answer

0 votes
answered Dec 22, 2016 by butchrichard (131,070 points)
 
Best answer
The issue is generally explained in this article.

http://support.presonus.com/hc/en-us/articles/215470663-Windows-10-Digital-Signature-Code-52-Error

There is currently no working solution for Legacy products on new computer's that meet the criteria for the new Microsoft Windows 10 Driver Attestation Securities.
...