Questions & Answers

Studio One request: better utilization of multicore chips needed as i9 chipset becomes more prevalent

+149 votes
asked Nov 20, 2017 in Hardware Integration / Remote Control by [email protected] (380 points)

I got a new system last week (see below) and Studio One is not running nearly as expected.  Hearing Pops and clicks with Device Block size < 64 and Process Block size of 128.  This is below the performance I got on my former system using an i7 chip without Thunderbolt audio interface with identical files.  My best guess is that Studio One is NOT using the power of the i9 7900x chip & board effectively. 

Consequently my request is to optimize Studio One so it can more fully take advantage of the i9 7900x motherboard and chipset and better show off the performance capability of audio interfaces like the Presonus Quantum.

To my fellow Forum readers- is it possible I am also missing some important adjustments to Studio One to optimize it in the higher performance environment of my new system?

Studio One Pro

i9 7900x 3.3 Ghz with native Thunderbolt support

64Gb RAM

SSD Drives

Presonus QuantumThunderbolt Audio Interface

12 Answers

+22 votes
answered Nov 27, 2017 by Skip Jones (166,750 points)
selected May 22, 2018 by AlexTinsley
Best answer

Thank you for the feature request. 

If anyone else agrees or disagrees, then please vote it up, or down. 

To vote:

In agreement click on the thumbs up.

In disagreement click on the thumbs down.

The developers pay close attention to those that are voted on the most. 

You are allowed one vote. 

Just viewing and agreeing but not clicking on the vote does not help the issue. 

Please click on one or the other. 

+5 votes
answered Feb 15, 2018 by danielbayer (2,980 points)
I totally agree. I just build myself a new system (with i7 8700k - 6 cores) and now I realize that S1 doesn´t really use the additional CPU power.

Bouncing is as fast/slow as on hte Macbook Pro (i7 with 4 real cores from 2012) I used until now - around 1.5x faster than realtime. A first test with 9 instances of Mai Tai (@Supreme) showed almost the same load as with the MBP while other tools showed only 35-50% utilisation of the CPU. The only positive difference is that the new system is significantly cooler than the old one.

Please PreSonus, unleash the power! :)
+3 votes
answered May 4, 2018 by wonder6oy (3,280 points)
I believe this request does cover what you are asking for...

...but heck, I'm voting here as well just due to the sheer monstrosity of the issue.  It needs to be dealt with asap.

Also using an 8700K btw; five of the six cores are barely even tapped into.
+1 vote
answered May 24, 2018 by diapasonprodues (2,560 points)
edited May 24, 2018 by diapasonprodues

Just built a system with a 8700k all cores running at 5GHZ but Studio One is only using 80% one thread and ~15% all other 11 threads!! Imagine the POWER it can achieve if it could use all cores equivalently!

This is still way better than my previous systems (4th gen i7). The new system runs a full session of nearly 100 tracks with full editing, mixing and mastering online, in realtime, with several pretty heavy plugins, melodyne, audio bend, and multiple virtual instruments, with barely any clicks and dropouts. But "barely" is still not enough, I want to be able to activate the Softube Tape MixFX without deactivating anything else and still hear clean playback.
+1 vote
answered May 24, 2018 by diapasonprodues (2,560 points)
edited May 24, 2018 by diapasonprodues

[ HINT (Solution) !!! ]

Right after typing my previous, I was reading on the web about this and had an idea. To decrease the buffer size of my audio device (StudioLive 32). Because I read presonus saying multicore was improved when they introduced the Dropout Protection and Low input monitoring (v3.5) and it separates the processing in different process blocks or something like that. I previously had SLive at 2048 samples and maximum dropout protection, when getting those results I mentioned before. But noticed the processing tab in SOne Options does not enable multiple block sizes when set up like that. I thought hey let's try putting SLive at 128 samples. And voila, my thread that was previously getting 80% usage was a little lower, and all other cores were a little higher. Already no more clicks and dropouts. So I though hey maybe if I set the hardware's block size as big as I can while not disabling Dropout Protection multiple block sizes, it works even better! So now my SLive is at 1028, and SOne at maximum dropout protections says 2048 samples block size, and I can see different monitoring latencies below that. Result is now I see half the threads running higher moving all over the place within 30%~50% usage, the other half is at about 30% usage, and that thread that was previously 80% usage is most often a bit higher than the others but never over 60%. 

Since I observed I start to get a few clicks&pops when the highest usage thread gets to about 80%, I can say I now have those 20% spare room to add even more before realtime playback gets glitchy. I am running that same whole huge session even with mix fx softube tape active (which is VERY HEAVY on the CPU). BEAUTIFUL! Everything is online and running in realtime with zero glitches.


(You should see different monitoring latencies for standard and low latency in the table at Options > Audio Setup > Processing. Looks like to me that setting the device's block size to the same number as the process block size causes Studio One to not use the multicore optimization from Studio One v3.5. Maybe they could fix that to still use multiple processing blocks even when the two blocks are the same size? Or perhaps set Process Block Size to 4096? Or maybe it is just that the Audio Device's buffer is still single-core and only the "virtual" internal processing buffer has been multicore optimized? In that case, is it possible to also optimize de Audio Device's buffer so we can get multicore efficiency even when not using Dropout Protection to have a bigger processing block size than the device's?)

+3 votes
answered Jul 10, 2018 by ssrmpc (320 points)
I also fully agree.

My i9 (18 Cores) load is around 30%. The CPU-Meter in Studio One 4 shows a load of over 80% and produces cracks.

According to some answers there is a trick of setting the block size and dropout protection.... but this is  just a workaround. I therefore kindly ask the development team to optimize the software in order to use the available hardware.
+1 vote
answered Feb 5, 2019 by franckmariani (3,230 points)
Same here,

New monster i9 and even if I’ve improvements, they are minor in term of capacity.

In Protools i pass from 60% to 18%.

That’s the kind of jump I’m expecting in so4
+6 votes
answered Feb 20, 2020 by markrobotham (2,960 points)
It`s 2020 and this is still an issue
+2 votes
answered Jul 8, 2020 by CadErik (510 points)
Same issue with Studio One 5... The CPU Meter shows 80% but my Windows meter shows 50%... that's on a Ryzen 7 2700 8 core processor... Plus if there is a way to tweak that with dropout protection and block size, it would be nice if this could be done automatically.
+2 votes
answered Jul 10, 2020 by evgen11 (230 points)
edited Jul 10, 2020 by evgen11

2020 year... the same problem. CPU 8700k. Dear developers, please pay attention to this problem, which has not been resolved since 2017. I really love Studio One 5 and I want to work in it in full force of my PC abilities. 

asked Oct 25, 2020 in Studio One 5 by jaimevsquez (230 points) Still the same?
0 votes
answered Oct 25, 2020 by jaimevsquez (230 points)
Hello there,

Is all still the same in October 2020? I Want to upgrade my 4 cores 4 threads cpu but reading this, meaby I should do something more...
–1 vote
answered Feb 19, 2021 by michaelpardus1 (2,700 points)
2021 - Studio One 5 - is still almost uselss with my i9. Bitwig handled far, far more plugins. S1 dies with 2 Acustica Audio plugins on one channel. It is still a distribution problem and a big one.


Use this software:

1.Install both Server and Plugin on same maschine
2. Launch Audiogridder Server and scan plugins (add path if necesarry). Disable video rendering (uenecessary on sam machine)
3. Launch Audiogridder Plugin in your DAW. It should discover server and connect automatically.

Now in Audiogridder plugin you can add all heavyweight VST plugins they will open in a Audiogridder container.


It's little hustle but it works and saves S1 *** for the moment.