Questions & Answers

Strange Midi Issue

0 votes
67 views
asked Apr 5 in Studio One 3 by philangus (7,220 points)
edited Apr 5 by philangus
Hi Guys,
Why are my issues always the most obscure!!?
I am running very latest Studio One V3 as at 05/04/2018 (I did a small update last night).

I have a Roland V-Drums (TD15) connected via USB for the midi and midi works absolutely fine. I am not using the midi interface on the Quantum at all. I never had an issue when using the Studio 192 (although I realise it operates slightly differently). I now have the Quantum. I want to stress here, there can be nothing wrong with my set up as everything else works fine and all midi works flawlessly except for this one particular issue, which is as follows:

When I play in to Studio One, either recording or just monitoring the drums, the open hi-hat does not sound. If I leave the hi-hat open and tap it, it just sounds like the closed hi-hat. After first opening S1, it will sound a small number of times, then as soon as I operate the foot pedal, it will revert to the closed hi-hat sound. At first I thought it had to be the pedal going faulty, but if I close everything down, plug my headphones in to the TD15 it plays absolutely fine. The other strange thing is if I record the hi-hat and operate the pedal in to a Studio One track, it records the correct events and when I play it back it plays it back correctly with all the open hi-hat events in the correct places and sound as they should. So it appears it is only something that occurs when monitoring. Because I do hear the first two or three open hi-hat hits correctly, then it reverts to the closed sound, I am wondering if there is some kind of buffering issue going on. This also happens even if I don't start the transport in S1, just hit the hi-hat whilst S1 is stopped. I am not sure which particular midi event is used for controlling the opening and the different levels of opening the hi-hat. I would imagine it is some kind of control event which adjusts the note on note off events for that particular sound (note). The fact is if I just operate the pedal and record the track it plays back fine and I can see the open hi-hat events in the edit window. If I click on the corresponding key in the event window it also plays fine.

I have an instrument (midi) track set up for the TD15 then an accompanying audio track to monitor the drums audio. The left and right outputs of the TD15 module come in to inputs 5 & 6 of the Quantum, so that audio track is set to inputs 5 & 6. All other drum sounds work fine, including the multiple different cymbal sounds when tapping the edge, the centre and the top for ride. Any idea what could be causing this?

3 Answers

0 votes
answered Apr 6 by robertgray3 (16,990 points)

I believe studio one only supports recording/editing polyphonic after touch on midi channel one or something like that. I dont use e-drums often so I’m not entirely sure of the workaround at the moment but if you look up polyphonic after touch on forums.presonus.com I’m sure you’ll find it. 

Here’s the feature request for it- if you like it vote it up http://answers.presonus.com/5701/will-studio-one-support-polyphonic-aftertouch

0 votes
answered Apr 6 by philangus (7,220 points)
Thanks, really appreciate you taking the trouble to reply. I will try setting the VDrums to channel 1 and see what happens. I don't really understand though why it seems to be OK for a few seconds then it suddenly stops and the open hi-hat sound reverts to the closed sound. Also, why does it play back OK?
0 votes
answered Apr 6 by philangus (7,220 points)

OK, so I worked this out and it turns out it's me being daft! I had Controllers filtered in the instrument settings. I had looked at these settings before but only at a glance and just assumed that ticked meant it was allowing these messages. It's only when I looked a bit more closely and thought about it, I then unticked it and it worked straight away! It also works on channel 10 so I am not really sure what people are referring to with the channel 1 suggestion.

I guess what made this more difficult to track down was the fact that it does seem to work for a while, but I think I now know also why this is, or why I had assumed that.

...