Questions & Answers

Failed to connect iRig HD 2 to Studio One 3

0 votes
35 views
asked Apr 23 in Studio One 3 by briantuason1 (150 points)
I tried to connect my iRig HD 2 to my Studio One 3 Professional PC 32 bit. And it pops out:

Failed to open Microphone (iRig HD 2)!

Please make sure that the sample rates of your recording and playback devices match

Then I click Manage audio devices to set recording and playback devices, which both are iRig HD 2, set them to the same sample rates, 24 bit 96000 Hz. And it doesn't fix. Tried another same sample rates and still no.

How can I fix this in order to record guitar using iRig HD 2 in Studio One 3?

1 Answer

0 votes
answered Apr 26 by AlexTinsley (680,610 points)
selected Apr 26 by AlexTinsley
 
Best answer

We reached out to IK Multimedia to help answer your question, this is what they had to say. 

Watch this video link to see the basic setup.

1. Download ASIO4ALL v2 here:  http://www.asio4all.com/ 
2. Install ASIO4ALL.exe 
3. Launch Studio One software. 
4. In your audio settings, select the ASIO4ALL v.2 driver 
5. View the ASIO4ALL Panel.  
6. You are now viewing the ASIO4ALL Panel, click the 'wrench' icon in lower right corner, a red 'X" will appear over it. This is necessary for you to select multiple interfaces for use. You will see various devices listed under the WDM Device List on the left. 
Click the enable/power button on both the iRig HD and your other interface that you will be listening to the output from. 
7. Once the above is set, view your audio settings window once again. Under Input channels, you can now view and select iRig HD as your input.  
Under Output channels, make sure your interface you are monitoring from is selected.  
Note:  Do NOT enable the 'Hardware Buffer' under Options in the ASIO4ALL panel, as this causes poor performance.

...