Questions & Answers

Audiobox iTwo / Win 10 - As soon as I stop playing sounds, the interface disconnects after a while

0 votes
168 views
asked May 15 in AudioBox i-Series by swiftlightcode (190 points)
Hello!
I seem to have a problem with my Audiobox iTwo. I'm using Win10 64 bit with the latest updates.
As long as I'm playing sounds, the interface works fine. But as soon as the sound stops and I turn off the game/music player/sound source, after a few seconds of silence I hear a slight crackle in the headphones and the device "loses signal" and no longer plays sounds from the PC, should I attempt to do so. Direct input seems to work fine, which makes me believe it's a software problem.
The only way to fix it that I've discovered is a "quickfix" where I open Universal Control (latest version) and force a firmware update, which produces another crackle and makes the device usable for a brief period. Should I not play any sounds within a couple of seconds, though, the device disconnects again.

I can't exactly tie the problem down to any event. I've tried to completely reinstall all Audiobox iTwo drivers and even attempted to run the legacy drivers as well, to no avail. I've also tried different USB (3.0) ports. The USB cable I'm using is the one that came with the package.
It seems to be a Win10 problem or an incompatibility with another driver that I can't seem to figure out. The only other audio drivers I have are the Realtek HD Audio and the NVIDIA HDMI audio ones, both of which I disabled. Audiobox driver is set to default. I have a hunch that the errors started when I updated the Nvidia drivers, but it's a guess.

Back on Win 7 it worked flawlessly... What could be the problem now? It's really frustrating. Even something as simple as switching between songs requires the quickfix because of the brief silence period.

Thank you.

2 Answers

0 votes
answered May 18 by AlexTinsley (731,240 points)
 
Best answer

Windows 10 has a feature that puts your USB ports to sleep when not in use. 

Open up Control panel and change the setting to disable this. 

Windows 10 removed the link to the control panel, so we have to get to it this way: 

  • On your keyboard hold down the Windows Button + R and type: Control (and hit enter). 
  • On the control panel screen select where it says: Power Options
  • Then select Advanced Power Options
  • Select USB Settings and there will be an option to change suspend setting to "Disable". 

You may also have to go into your BIOS and set the USB Suspend setting to make sure the motherboard doesn't do this on it's own without the help of the OS. 

0 votes
answered May 22 by swiftlightcode (190 points)
Thank you for the answer. I checked these settings, but the problem persists. Please advise.
...