Questions & Answers

Midi playback Problems

+4 votes
3,645 views
asked Jun 6, 2018 in Studio One 4 by ameliajoffer (160 points)

I have encountered a problem when playing my MIDI keyboard (Nektar LX49+) to Presonus Studio one. The recorded MIDI notes show the full and proper duration they were held down for, yet when I play them back, only the initial attack is played in the form of a quick staccato note and the rest of the duration of the note is silence. In Real time, I'm able to sustain notes and use my pedal, but when I playback the recording I run into these issues. Can someone explain why this might be happening?

8 Answers

0 votes
answered Jun 13, 2018 by davidburke1 (360 points)
Greetings, Ameliajoffer!

I'm sorry to hear of this problem, and I don't have a solution, yet.  But I can tell you that I'm having the EXACT same issue, AND it didn't start until I upgraded to Studio One 4.

My keyboard is a Yamaha Stage Piano CP33, and what you've described is identical to what's happening to me.  I can, however, add the notes manually with my mouse, and they work fine.  But using my keyboard is a staccato disaster.  At first, I thought the issue was a reverse polarization of my sustain pedal -- something that's not uncommon.  But after further investigation, I've determined that the problem happens with my keyboard when using it in midi mode.

Please write back ASAP.  I need to know if you've made any progress to fix this problem.

Thanks!

David
0 votes
answered Aug 19, 2018 by patrickjoseph (140 points)
Hi there,

Just wondering if you got this solved.  No idea why this is not working for me, can see the midi data recorded the way it should be, it's not playing back the those rhodes / soft keys that I played earlier, and are there!  Mystery ... have looked everywhere, and I am sure it used to work before as well.  Pls help.   Thanks.
0 votes
answered Dec 10, 2018 by alexronin (210 points)
Same problem here! Like davidburke1 said playback sound as a staccato disaster! Someone has resolved this problem? Thank you...
0 votes
answered Mar 15, 2019 by christopherfuller2 (230 points)
Best solution I've come up with is changing the Quantize in Midi Mode. When I had mine on 1/8 it was causing that but if I changed it to 1/16 or 1/32, that specific problem was resolved. I just get some held over notes on playback.
0 votes
answered Aug 31, 2019 by xbxuulns (220 points)
edited Aug 31, 2019 by xbxuulns
0 votes
answered Oct 24, 2019 by richardmusick (220 points)

Try Studio One: Options: External Devices: (Click on your device), Check Mark "Default Instrumet Input". This worked 4 me..

+1 vote
answered Apr 9, 2020 by zdravkobozic (200 points)

Very simple solution. The DAW is receiving two MIDI signals at the same time.

Go to Studio One / Options / External Devices ; and Remove any doubled input device that has an identical Receive From.

0 votes
answered Dec 1, 2021 by antsteep (630 points)
I have this problem too. I can record midi and it sounds just fine. I can't play it back. It will just change long notes to staccato or not play at all. I have check all automation lanes for phantom data. I have put the midi on different instruments. I have tried saving it as a loop and opening it in a different project.

I simply can't record MIDI and have it play back. Back to Logic it seems.
...