Questions & Answers

Can I use ASIO4ALL with an AudioBox Series Interface on Windows?

–2 votes
6,114 views
asked Dec 12, 2015 in AudioBox USB by AlexTinsley (753,460 points)
The customer is having an issue with playback when using ASIO4ALL with his AudioBox 22VSL. When ASIO4ALL is selected as the Audio device, it  prevents the program from playing. When the play button is pushed, it highlights and there is no movement or audio playback. The playback is not affected with using the AudioBox as the device. His computer does have distortion issues when in use.

The customer uninstalled and reinstalled Native Instruments software, Reinstalled ASIO4ALL and drivers. Got Windows to work with the AudioBox for playback, but still having issues with the playback in Studio One.

How can this be fixed?

1 Answer

+3 votes
answered Dec 12, 2015 by AlexTinsley (753,460 points)
 
Best answer
At no time do we suggest using the ASIO4ALL driver nor do we support the usage of ASIO4ALL.

- This will need to be removed.  They need to be using the drivers PreSonus provides for their products.

http://www.sweetwater.com/sweetcare/articles/audiobox-usb-audioboxs-asio-driver-initialize/

http://www.audiorecording.me/asio-vs-wdm-best-practices-in-modern-home-recording.html

============================

Please check out these two guides, which will assist you in setting up your AudioBox:

1. This guide covers common AudioBox setup and configuration issues, as well as addresses basic reasons for the device to not seem to function properly:

http://support.presonus.com/entries/21351334-why-won-t-my-audiobox-record-or-play-back-audio

2. If the above guide does not resolve your issue, the driver may need to be uninstalled and reinstalled properly. Below are instructions for how to do this:

Windows Vista and Windows 7:
http://support.presonus.com/entries/21524610-how-do-i-uninstall-and-reinstall-my-audiobox-drivers-in-windows-7
...