Questions & Answers

No thunderbolt device handshake/sync upon start up with PC laptop.

0 votes
19 views
asked Oct 30 in Thunderbolt - Quantum by harryharris1 (200 points)
I have a Asus Zenbook Pro laptop (T3 ports) with Windows 10 Pro and Quantum 2 interface. Both laptop, quantum, UC and windows have been updated incl the bios. Am currently using the Apple T2 to T3 adapter. However when powering up the Quantum and then the laptop I do not get a handshake/sync between the laptop and the Quantum (Quantum power light is red) and the UC  app shows no thunderbolt device attached. I checked the windows services and both the presonus and thunderbolt service is set to automatic (delayed start). I tried different thunderbolt settings in the bios but no difference. When I disconnect the T2 cable from either end and then reconnect, in about 5 sec the Quantum power light goes blue and the UC shows Quantum device attached and everything works normally in Studio One or Reaper. However when I power both units down and power back up I get the red light again and no connection. I then have to disconnect and reconnect the T2 cable again to get things working.

It appears there is an issue with the thunderbolt device handshake upon power up at least for my setup. Not sure that the StarTech adapter will fix this as the Apple adapter works fine after disconnecting and reconnecting the T2 cable. There is very little info on this from Presonus except the recommendation of using the Startech adapter. What is the difference between the two adapters? Does anyone know if the Startech adapter will fix this issue or is there some handshake issue with the Quantum 2 and certain thunderbolt 3 PC ports. Any help on this would be much appreciated and others might find the same situation etc.

1 Answer

0 votes
answered Nov 1 by harryharris1 (200 points)
I read in another post that the T2 to T3 Apple adapter would work with some ASUS laptops. In my case it only worked, after powering and booting up both the Quantum and laptop with all cables plus adapter attached, by disconnecting the T2 cable from the Apple adapter and then reconnecting it. The Quantum power light would then turn blue indicating sync and then work normally. All updates were done and settings configured as needed. The only fix for this issue was getting the Startech adapter. Using that device everything worked incl the power up and sync with no issue of having to disconnect the T2 cable and then reconnecting etc. If you are building a new DAW system, laptop or not, with Thunderbolt and Quantum it is probably worth just purchasing the StarTech T2 to T3 adapter instead of trying the Apple one. Not worth the difference in cost vs time dealing with possible issues with the Apple adapter.
...