Questions & Answers

XR digital mixer no longer connects

0 votes
76 views
asked Nov 26, 2018 in Studio One 4 by timlewis6 (380 points)

I'm having trouble connecting a XR-18 digital mixer as an audio device.  The error message I'm getting is:

"The audio device XR could not be initialized, please check your hardware configuration and try again"

The system was working correctly last week.  I was able to record and play back audio.  But yesterday I tried doing a recording and got this error message.

More information:

I'm using a Toshiba notebook with an Intel i5 CPU running a brand new installation of Windows 10, fully updated, and a brand new installation of Studio One 4.  I set the whole thing up for the first time last week.

I installed the latest XR-18 drivers from the manufacturer's website, and they worked just fine until yesterday.  When the system stopped working, I tried reinstalling the drivers.  This didn't help.

I know that Windows is seeing the XR mixer, because it appears in the Windows control panel under "devices" when I plug it in, and the device disappears when I unplug it.  Oddly, however, Windows doesn't make the USB connect/disconnect sounds when this happens.  Does that matter?  

I've tried two different USB cables on the chance that it's a cable issue.  This didn't help.

I've tried installing ASIO4ALL to see if I could talk through it to the XR-18.  ASIO4ALL sees the mixer and lists the ports, and I can see the listed ports in Studio One, and select them as audio inputs/outputs.  But when I try to record, the record button turns red and then nothing happens -- and I mean absolutely *nothing*.  The timer doesn't even advance, so I can't record from MIDI devices, or anything.

Any ideas?

Thanks!

1 Answer

0 votes
answered Dec 16, 2018 by timlewis6 (380 points)
I'm going to answer my own question in case anyone else has this problem.  In my case, the problem had something to do with the USB connection between the mixer and the computer.  Although the XR-18 was showing up in Windows when I would plug it in, something in the hardware (I'm not sure what) wasn't connecting correctly.  The problem went away when I plugged the XR mixer into a USB hub instead of plugging directly into the notebook computer.  I find it very odd that this helps.  I thought that the notebook USB port or the cable had a bad contact, but I tried two different cables, and multiple USB ports on the notebook with no success.  For some reason the port on the USB hub fully connects and the ports on the notebook only partially connect.  I mentioned that Windows doesn't make the USB connection sound when I plug the mixer into the notebook.  This is still true for the notebook, but when I plug into the hub, Windows makes the connection sound.  This must be a hardware issue, so it really has nothing to do with Studio One.  Still, it might be useful information for someone.
...