Questions & Answers

Plug-in scan fails in Studio One 4.5

+4 votes
3,610 views
asked May 22, 2019 in Studio One 4 by xubnzppc (190 points)
edited May 22, 2019 by AlexTinsley

http://answers.presonus.com/?qa=blob&qa_blobid=9668987153161005825

I am a Presonus Studio one 4 user.
I was able to use this software without any problem up to version 3 and version 3.5.


The following problems have occurred since version 4 and version 4.5 where "Plug-in Scanner" was introduced.
The plug-in scanner is displayed as "●● (the plug-in name) failed to scan" when starting up the DAW, and it is not possible to load all third-party plug-ins other than the Presonus-provided plug-ins.
The symptoms are as the attached image.
All 531 plugins fail to load.


To solve this problem, I did all the following:


■ Uninstall and reinstall Studio onen using various software such as "Revo Uninstaller"

■ Resetting and rescanning of blacklist by Studio One

■ Check if the installation location of the plug-in is appropriate (all of them are placed in the correct directory of Windows, and Studio One side exists in the default location where the plug-in is loaded)

■ Security software off and operation permission of each software by security software

■ All execution authority is given to each software


I am not a PC or DAW beginner.
At work, I sometimes advise people about music software related errors and even help them solve them.
I tried everything I could come up with to solve the problem.


In Studio 3.5 you can load plugins as before.
The addition is successful even after installing the new plug-in.


Because of this, I have failed to uninstall Studio One 4 completely, and I expect that some files related to Studio One 4 remaining after repeated uninstallation cause this error. You


Please tell me how to uninstall Studio One 4 completely.
I think that there are log files and registries that can not be completely removed by normal uninstallation or uninstallation using uninstall software.
I want to know where the file exists.


When I succeeded to completely uninstall Studio One 4, I think that I can finally install this software in a completely clean environment, and the plug-in loading is likely to be normalized.


I became a Studio One user from a SONAR user and had a very comfortable experience.
That is why I feel serious about the problems that are occurring now, and I would like to solve them anyway.

Thank you.
 

3 Answers

–1 vote
answered May 22, 2019 by AlexTinsley (902,880 points)
 
Best answer

If you have upgraded to Studio One 4.5 and your plug-in scanner is hanging when launching the program, it is because you are offline. One solution to this issue would be to go online with your computer. If this is not an option, here is what you can do...

  1. Go to Run in the Windows Start menu or open Cortana. Type in %appdata% and press enter. From the Roaming folder that appears, go into PreSonus/Studio One 4

  2. From the Studio One 4 folder, go into x64 and locate the Vstplugins.settings file. Right-click the file and choose to open it with Notepad.

  3. In the Vstplugins.settings file, locate the following line: <Attibutes scanAtStartup="1">  Change the 1 to a zero and save the file.

This workaround will prevent Studio One from scanning plug-ins on launch and should resolve your issue. Previously scanned plug-ins will still load. Another option is to install the 4.1.4 build of Studio One and go into Studio One>Options>Locations>VST Plug-ins. From here, you can un-check the "scan at startup" option. You can then install Studio one 4.5 after doing this, to get around the problem.

If you would like to roll back to a previous build, you can. Just log into your my.presonus.com and go to My Products>Software>Studio One 4. There is a link to view previous versions. You can download 4.1.4 from this list. Just uninstall version 4.5 and install version 4.1.4. Please check future release notes to see if the issue has been resolved.

0 votes
answered Nov 23, 2019 by irenenachreiner (140 points)
I don't have an answer.  But I have the same exact problem.  This is making me crazy.

Please fix this issue.  I need to use Synthology Ivory!!!!

PreSonus techs, please fix this issue.
0 votes
answered Dec 4, 2019 by hermanwilliams (460 points)

This is a temporary fix, that did work to bypass scanner.   I had same error with PlugIn alliance.  It added a couple of hundred extra plugins, and it was taking forever to scan.  I may uninstall the PlugIn Alliance.

...