Questions & Answers

Studio one won't open with Mac OS Catalina

–1 vote
asked Jul 21, 2019 in Studio One 4 by zachdunn (160 points)
I upgraded to the most recent os for Mac. OS Catalina. Since upgrading most of my music applications will not open ( studio one professional 4, slate digital etc.). The prompt comes up that I need to contact the developer for an updated version. Any solutions ?

3 Answers

0 votes
answered Jul 29, 2019 by AlexTinsley (906,400 points)
Best answer

Catalina introduced a new feature for dealing with software it doesn't recognize. 

This is the error you are seeing:

In the Applications folder, Control+Click the Studio One icon. Or, if you have a 2 button mouse, right-click the Studio One icon. 

 A contextual menu pops up. Select "Open."

Then in the next screen, there will be an option to select "Open" again. Click it.

The install will complete and you can then use Studio One. 

This appears to be a new feature in Mac OS X 10.15 related to an emphasis on higher security in the OS. 

If you're installing Universal Control, please refer to this other Answers article which references a similar situation in Mac OS X 10.15 Catalina -

0 votes
answered Jul 21, 2019 by chrissederqvist1 (2,300 points)

I upgraded to the most recent os for Mac. OS Catalina.

 This is not really the case. macOS Catalina is not the latest version of macOS, Mojave is. Catalina is the upcoming version, now in a stage 3 beta.

You've installed the latest BETA operating system, NOT a final release.

You should never expect production quality experience when using pre-release OS versions, and especially in conjunction with DAWs.

Usually you should wait to get a "green light" from the creators of the software you depend upon, before installing an OS upgrade.

I also tried the Catalina beta, but not on a production machine, and as you experience, not much worked except basic applications. Lots of plugins didn't load, and the system was basically what I'd expect from using a beta; rather useless.

This will get fixed, but until then, you have to follow the system requirements for the software you want to use. In the case of Studio One 4, this is macOS Mojave. Catalina isn't supported officially on any DAW that I'm aware of at this time.

Take Avid's Pro Tools as an example, they just recently got a version up and running on macOS Mojave, and that's almost a year after the first release. Still many Pro Tools users can't upgrade to Mojave because of various DSP issues and whatnot.

You have to have some patience, bro.

0 votes
answered Sep 25, 2019 by joesmith64 (140 points)

First check either the app is compatible with your device or not.

  1. Click on the Apple logo in the upper left corner. 
  2. Select About This Mac > System Report
  3. Navigate to Applications under the Software tab. 

Find your app on the list and check whether it says “Yes” in the 64-bit column. In macOS Catalina, there will be no such column. So, you’ll have to click on the app and see a short description that says “Kind: 64-bit.”                                                            

If it is compatible then you can contact Macbook Repair SIngapore to resolve your issue.