Questions & Answers

Studio 1824c upper sample rate issues 176.4 khz / 192 khz unavailable

+2 votes
86 views
asked Aug 26 in Studio Series USB Interfaces by marshallbilodeau (140 points)

I have a Studio 1824c running on a MacBook Pro with Mojave 10.14.6.  When I set the sample rate to 176.4 or 192 in the universal control app the Studio 1824c clips out--all the 8 input LED's light up as well as the output LED's,  The sound that comes out of the unit when this happens as awful! Can anyone shed some light on this situation?  Has anyone else run into upper sample rate problems with similar hardware?  

The lower sample rates 44.1 and 48 khz seem to work fine, as does 88.2 and 96 khz but anything above that won't work. 

Studio 1824c Clipping

3 Answers

+1 vote
answered Sep 1 by joeswatsell (200 points)
I BOUGHT THE SAME UNIT WITH THE SAME PROBLEM. I AM NOT GETTING MUCH HELP FROM PRESONUS. I ONLY BOUGHT THE UNIT FOR 192k USE. I BOUGHT A DIFFERENT BRAND AND IT WORKED AT 192k FOR ABOUT 1 MINUTE.  THE FIDELITY WAS ON BELIEVABLE, BUT THE UNIT KEPT CRASHING. 192 ONCE YOU USE IT YOU WILL NEVER GO BACK. LISTEN TO THE TOP ENGINEERS IN THE MAJOR STUDIOS, THAT'S ALL THEY WILL USE. IF YOUR COMPUTER WON'T RECORD AT OR PLAY BACK 192k THE WAY IT SHOULD THEN YOU WILL NEVER HEAR IT CORRECTLY. THE TESTS YOU LISTEN TO ON YOUTUBE ARE NOT CORRECT. LISTEN TO AL ON YOUTUBE HE WILL TELL YOU STRAIGHT.
0 votes
answered Oct 23 by stefanmiehle (160 points)
exact same issue and no solution. Is there anyone supporting us from PreSounus? Using a iMac and USB-C.
0 votes
answered Nov 20 by danamberman (160 points)
Same problem on Windows 10.  Reported to PreSonus Support but no solution provided.  They claim it's a known problem but it ended there.

I use a Steinberg interface on the same pc at 192 Khz without problem.  I purchased the PreSonus 1824C expecting it to be a major upgrade to what I was using but I've been limited to 96 Khz and below sample rates since purchasing.
...