Questions & Answers

StudioLive equipment as devices for network testing

0 votes
127 views
asked Aug 29 in StudioLive Series Feature Requests by juergenboehme (450 points)

While checking the forum I found that more than one person reported problems with audio dropouts on the network connection between a StudioLive mixer and equipment connected by a network cable like the NSB 16.8 or a Rack Mixer.

There is always the recommendation of the support to check if the cables meet the requirements. There is a quite interesting article posted here about network parameters:

https://support.presonus.com/hc/en-us/articles/360031841952-Ethernet-Cables-for-AVB-Guide

When I read this article first I understood that this AVB network connection is different from the network connection other companies are using to connect digital snakes to mixers. Not only this, I found that AVB is seen as the next generation for network protocols. It offers many possibilities while also taking responsibility that there are no big delays in audio playback even if a certain number of devices is connected to such a network.

I try to explain this slowly because I assume that many people here might be not completely aware that a network connection is different from a simple audio connection.

A normal audio connection has only one level of operation. If you connect a guitar with a cable to an amplifier and the cable is broken you will not hear a sound. If the cable is fine you will hear a sound.

A network connection is a different thing. When you connect two devices with a network cable and the cable is broken it will also not work. But a network connection might also not work even if the cable is fine (good condition, not broken). This is because network signals carry more than one level of information. It’s like a letter you want to send to another person. If you have only the letter the postman will not know to whom he should give it. You need to put this letter into an envelope and put an address and also a valid stamp on it. If this is there the letter should reach the desired person.

This is what happens on a network connection. Not only the audio signal is handled there but also informations about the target which should play the audio. Also the device on the start of the cable should have the same heartbeat (clock) as the target. Both devices need to work hand in hand synchronous to properly deliver what is provided.

I was also experiencing these kind of dropouts other people are describing here. I didn’t want to accept them. But what can be done to catch the bug? You just don’t know if the problem is with the cable or with one of the devices. You only can change parts until it works. But you don’t get any information what is wrong to avoid the faulty situation the next time. You have to live with try-and-error to solve a problem.

If the quality of the data connection and the provided data is that important for a proper AVB connection, could we get a possibility to check if the cable I have in my hand meets the needs of this AVB connection?

Of course there is network diagnostic equipment available from companies like Fluke. But an appropriate device that can check the quality of an AVB connection might cost several thousand Euros.

Would it be possible to program such a network testing capability into the firmware of the mixer and the other Presonus devices? When pressing the “home” button I see seven icons. There would be the space to add a new function “Network diagnostics”.  This function should switch a mixer and e.g. a connected NSB 16.8 in a mode where a testing routine can check the connected cable if it meets the needs of a proper AVB connection.

Additionally there might be an extension. If you have an audio network with more than one device and more than one network cable it should be possible to define between which devices the network connection should be checked. In the audio routing section all devices are visible who are currently available in the network.

I think the Presonus devices have so much DSP power. Would it be possible to write a new firmware with which the devices can operate as qualified network-testing devices?

Compared to an external testing device this would have the advantage that also the cables and network contacts could be checked from exactly those devices which later on trust in a stable and high-quality AVB-connection?

I would like to perform the following task with my Presonus mixer and a NSB 16.8 instead of the Fluke devices:

Using a NSB 16.8 as end device the +48V LED´s could be used to show status reports similar to the green LED’s on the Fluke endpoint device.

The mixer is already able to perform a real time analysis (RTA) on incoming audio signals to show the used frequencies. It would be great if this calculating power could be used to check the already connected cables and print out cable quality reports delivered by the UC software.

13 Answers

0 votes
answered Aug 30 by jonnydoyle (216,540 points)
 
Best answer

Thank you for the feature request. 

If anyone else agrees or disagrees, please VOTE!

The developers pay close attention to those that are voted on the most. 

You are allowed one vote. You can change your vote later if you choose.

(Here's some helpful info on how to use the voting system)

Please vote the original question / feature request. 

Please DO NOT Vote on THIS response!

0 votes
answered Aug 29 by wahlerstudios (82,900 points)
Nice idea, good reasoning, something for PreSonus to think about!

I just wanted to "correct" the picture a little bit. There are definitely problems and you find many hints in the Forum, in "Answers" and in the public and the closed Facebook groups and seldom you get to know if and how the problem was solved. Fact is that in most or nearly all cases the problem is the user. It's definitely not the product or the construction and development work of PreSonus! The biggest problem is to understand the two directions of AVB streams and how to delegate the sources between two and more items. And it's often the case that users have messed up patching and routing, without knowing it. They also have no idea how that works with presets and scenes and that it's absolutely necessary to perform a Master Reset additional to the resets of project and scene, before any network settings are set or recalled. Without a "clean" start, things will most likely get difficult.

It is a question if a new function (Network Diagnostics) could help to prevent user mistakes. People rather "do" things than read to get to know the "how to" and "what not "... By the way, cables are seldom a problem. Even cheap CAT5e cables do work reliable...
0 votes
answered Aug 31 by juergenboehme (450 points)
edited Aug 31 by juergenboehme

In this case it is definitely not an „Error 40“ (this kind of  error which is located in 40 centimeters distance in front of the monitor …)

Sometimes the connection is stable for the “big” time of 20 minutes, then suddenly dropouts appear. Sometimes one, sometimes two, sometimes ten or twenty in three to five minutes. Then suddenly the system is stable again and nobody knows when the next dropouts will appear.

It seems to be not an issue of the settings.

 

Concerning sync:

In the stagebox setup the output source is set to “AVB Send 1-8” and besides the name of the stagebox the green sync indicator is visible. When I set the output source to “none” and press “Apply” the green sync indicator disappears. Instead there is a message on the screen that an output source needs to be selected to enable AVB clock sync.  But the box can also play audio without this sync setting. So this is not the problem.

 

Concerning reset:

On top of the Digital Patching screen there is this green “Master Reset” button you can touch which will return all input and output digital patching to the factory default routing for all inputs and outputs (analog and digital).

In the scenes screen you have two reset buttons which unload the current scenes and projects and return the settings to factory defaults.

Are there more places with reset buttons I have not seen yet? Of course when powering on I start the mixer first and then the stagebox so that the AVB listener (stagebox) can find an active AVB talker (mixer) on the network when initializing.

 

Concerning cabling:

It is not an issue with the cabling. The dropouts appear even if there is only one StudioLive 16 connected with one blue Presonus network cable (length 1,50 meters) to one NSB 16.8 stagebox on AVB-input A.

 

Concerning routing:

I was able to hear a device connected to the stagebox on the mixer headphone output. Then I set one Earmix device to receive audio streams on the first and second channel (AVB channel 49 and 50). In the mixer I routed Mix 1 and Mix 2 to be directed to AVB channels 49 and 50, selected Mix 1, raised the faders of my input source to nominal level, also the sum-fader for Mix 1. Same for Mix 2. As result I could hear  the left channel of the audio source on Earmix channel 1 and the right channel of the audio source on Earmix channel 2. I could do a separate mixing there, with panning, EQ Limiter and Level. So I understand the routing of this ecosystem.

 

Of course there are differences between cables. I started with Cat 5 because it was not clear that at least Cat 5e should be used. The blue Presonus cable is Cat 6 unshielded. Now I have everything in CAT 7 where everybody says that this is not necessary. I see at least three improvements when using CAT7: The initialization of the stagebox in the beginning works faster. When you switch on and off phantom power on a channel the phantom power LED’s on the stagebox react faster. Most important for me: The sound seems to be more open in the high frequencies. Maybe not much but noticeable. When listening to music for a longer time the sound is more relaxed on Cat 7 than on Cat5.

The dropouts appear on both types, the blue Presonus cable and the Cat 7 tourgrade cable with professional Neutrik Ethercon connectors. If Cat 5e cable is sufficient for a digital connection a Cat 7 connection should do this job with ease. But it doesn’t.

The problem seems to be an issue with the network clock. The sync gets lost and then the Audio stops. When you press the home-button and select the system screen there is a network clock indicator which switches from green to red in a timeframe from about two seconds before a dropout and five seconds after a dropout. Sometimes in cases of small half second dropouts you might not see a change from green to red but in most cases the red status correspondents to a dropout.

 

Exchange some hardware?

I originally purchased a new StudioLive 16 III mixer, two new NSB 16.8 stageboxes, one new AVB switch and two new Earmix devices. One NSB had issues with dropouts from the beginning, the other was quite stable. The first device I gave back to the dealer was the mixer because the select buttons on Channel 5 and 6 didn’t work. The StudioLive 16 is no longer delivered to the dealers, only the 32 SX is available in this size. But it has no longer the small displays in the dynamic fat channel which I see as advantage in some situations.

Therefore I got the last StudioLive 16 of the dealer from the demoroom. The next part I gave back to the dealer was the one stagebox that had the higher amount of dropouts. I got a new Stagebox. Unfortunately the new box had also dropouts, but only on input A while AVB B delivered a good Signal (even though both Inputs should be parallel).

With the second originally purchased  stagebox the connection mostly was stable, even after three hours of operation. Therefore the mixer as master clock source seems not to be the problem if one stagebox is working. So I gave the exchanged stagebox back a second time, also to be able to purchase the Cat-7-cables which are more expensive than Cat 5e. Also I exchanged the snake cables two times. First I purchased the recommendation of the dealer, a 75m-Cat-5-drum. I exchanged it to a 50m-Cat-5e-drum, and I returned this one again to order the current 75m-Cat-7 drum.

Unfortunately now this second stagebox shows also dropouts. I don't think that there is a hardware problem. The bug is somewhere in the data handling / protocol operation.

In the forum here I read from other people about similar dropouts combined with red/green signals from the network clock indicator. The descriptions sound similar to my issues.

There is no problem with standalone operation of the mixer, no dropouts or anything else, just a workflow and some features that I prefer compared to the digital mixers from other manufacturers. In general this is a very competent and well designed product and I would like to get it working.

I fear if I would open a ticket to check this device it would be sent back to me after some weeks without any error detection.

I think most people here don’t have these kind of problems because most people outside are not working with digital snakes. Or most of them are no computer technicans and don’t understand that this issue they are talking about might be not hardware related but located on the protocol level where device communication takes place. And therefore they would not set a “like” to this topic here.

So I’m asking for a possibility to check my devices to get an idea why the network clock gets lost. The complete calculation engine of this mixer is designed to work with the channels in the network connection. Therefore it should be possible with a different software to review and qualify the measured data. What was taking place in which part of the mixer when a dropout appeared?

Currently no music is playing, nobody touches the mixer, nobody touches the cabling. The green light besides the network connector is constantly flashing, the amber light is constant, and three minutes ago the green network clock indicator in the system screen changed from green to red for 15 seconds. Why  was the system out of sync?

 

So even if there might be not many likes for this topic here I as a single person ask for a diagnostic software which runs inside this ecosystem and is able to report issues.

 

Fluke might be a professional company with high quality tools that might be able to clarify unclear situations. But they have no solution which is able to report issues in a StudioLive eco system.

There is the need for diagnostic tools in event situation where the audience expects from a technican to solve a problem that the show can go on. I purchased this equipment to do some interesting jobs with it. Currently I take it sometimes out of its cases, place it on my table in the living room, connect one stereo device to it, play a little bit around with it, thinking if it’s worth the risk to try it in a professional situation.

When the diagnostic reports would show that the problem is the mixer I would open a repair ticket. But I don’t want any longer go to the dealer and ask for an exchange of parts for try-and-error-diagnostics. In the meantime I think they start rolling eyes when they see me coming and describing issues with Presonus equipment.

 

So why does the network clock indicator change to red sometimes even on professional and Presonus recommended cabling (blue cable) with only one sound  device connected on the stagebox in a short distance?

 

Regards

Juergen Boehme

0 votes
answered Aug 31 by wahlerstudios (82,900 points)
Interesting to see that there is so much more "behind" a feature request... I asked PreSonus Support (Irleand) to chime in, but it's weekend, so have a little patience. I am trying to understand your long response and find the right answers. As a "normal" user my knowledge is limited, but I own a SL 16, a 32R, a 16R, three 16M and a SW5E, so I do have some idea about a few things... ;-)

"Concerning sync" - the NSB stageboxes need at least two AVB banks selected, one "input" bank and one "send" bank. Setting sends to "none" will definitely result in dropouts. "The box can also play audio without this sync setting" - yes, until the dropouts start...!

"Concerning reset (1)" - yes, there are I think two more places for resets. The most important one is in UC Surface (Settings -> Digital Patching -> Master Reset).

"Concerning reset (2)" - PreSonus recommendeds the order NSB first, mixer second. I was also astonished to read this (in the closed Facebook groups), because the manuals do not say so and the talker/listener idea would say mixer first, stagebox second.

"Concerning cabling" - correct, its not a cable problem.

"Concerning routing" - in the "StudioLive_Series_III_OwnersManual_V6_EN_10062019" are now in section 14.2 "Digital Routing" some charts, which explain the default routing (14.2.1 Input Source, 14.2.2 Analog Sends, 14.2.3 AVB Sends, 14.2.4 USB Sends, 14.2.5 SD Card). In a setup with EarMixers it makes sense to use the newly added eight AVB sends as "Source 2". I add a short overview:

AVB 33+34 = AUX IN 1
AVB 35+36 = AUX IN 2
AVB 37+38 = TAPE IN
AVB 39+40 = MAIN L/R

AVB 41-48 = FLEX MIXES 01-08 (aux, matrix, subgroup)

AVB 49-56 = 16Ms Source 1 (channels 1-8)
AVB 57-64 = 16Ms Source 2 (channels 9-16)

The discussion about the cables (CAT5e vs. CAT6 vs. CAT7) needs some expert know-how. I have read lately that you CAN'T hear a difference between the cables...

"Exchange some hardware?" - repairs in Europe  are made in Holland, so this should not take too iong, but I can't really think of hardware problems here. Even Select buttons can be "healed" by special procedures Support will tell you. No, we have to do with network(in) problems and just today I read that PreSonus is working on a solution for the nasty NSB network problem, as they did for the EarMixers.

Hope this helps.
0 votes
answered Sep 1 by juergenboehme (450 points)
edited Sep 2 by juergenboehme
Concerning the select buttons – even if there is a procedure to „heal“ them which the support can tell me, should this be neccessary for a device fresh from the dealer?

Last morning I switched the system on (NSB first, mixer second) as recommended. The blue Presonus network cable is used. I connected my Tascam Minidisk device to the stagebox and started playing music. It worked fine for 50 minutes, no hearable dropouts at all. Then suddenly dropouts appeared. I restarted the system (NSB first, mixer second). It was not possible again to listen to music without dropouts. Sometimes they appeared after 10 minutes, sometimes after two minutes, sometimes after 15 minutes.

In that moment I had to leave. When I came back I switched the equipment on again (NSB first, mixer second) and performed the Master reset and the project reset and scene reset.

This time the first dropouts appeared after 10 minutes, the first one short, the second one about two seconds. When dropouts appear you can hear them on the main outputs and on the monitor network devices. All the level meters on the devices go down when the dropouts appear. So the recommendation for the power switching sequence didn’t solve this issue. It seemed to work first but was not long lasting.

Also there was again the network clock indicator changing from green to red around the dropouts. Not in every case, some droupouts caused no colour changes, and sometimes colour changes of the network clock indicator take place without audio dropouts.

In my job environment we are dealing with Cisco IP phones. In case of errors there is the possibility to switch on a logging mode where the network communication can be reviewed to get an idea what has happened. There is an event protocol file with timestamps which can be sent to the support technicians.

In case dropouts appear this must have a reason and there should be a possibility for diagnostics other than sending the complete equipment to the support. In case a cable is causing the errors (which can happen in live situations) there must be a possibility to find out which part of the system is causing instability. Otherwise for professional use it is better to go back to analog snake technology where you work only with the available physical connectors of the mixer which seem to be stable.
0 votes
answered Sep 2 by wahlerstudios (82,900 points)
I heard from Support that they will take care for you. Thanks for some more observations. From what I can read there is an "issue" with the NSB stageboxes and PreSonus is working on a solution. It will be interesting to see what the solution will be.

Let me add that i don't experience any dropout problems with my two rack mixers (32R and 16R) and three EarMix 16M, connected to a SL 16. I am talking about hours of use, not just a short testing...
0 votes
answered Sep 2 by juergenboehme (450 points)

Today I checked the configuration when there are no daisy-chained connections but each device is connected to the switch directly. Studiolive 16, two earmix devices, one NSB 16.8. In general this configuration seems to operate more stable than a direct connection between stagebox  and mixer.

But also here noticeable dropouts appeared beginning about 20 minutes after the start. Sometimes short, sometimes longer.

Currently one network port on the switch and the Ethernet port on the mixer are not used. So there would be space for a connection to the normal ethernet and to the AVB system if a diagnostic software would be available to monitor network-, clock- and AVB-data and events.

I have planned a first stage job for the mixer on 21st of September and I originally wanted to show the advanced possibilities of modern digital mixing to the band. Looks like I will have to operate the system without all the network parts on my current 16-channel analog cable with two mains and only one monitor channel for all.

0 votes
answered Sep 2 by wahlerstudios (82,900 points)
If you let the NSB stagebox away and use just the EarMixers, do you still hear dropouts?
0 votes
answered Sep 3 by juergenboehme (450 points)
edited Sep 3 by juergenboehme
I think I know where the problem is.

First I tried the setup only with the mixer and one EarMix. No AVB switch, instead the external power supply for the EarMix. Stable situation, not any small dropout at all for more than one hour. For the first time during the last four weeks … day of hope ...

One reason for sync problems can be a low quality of the network cables. This should not be the case here. In an AVB network there should be one device act as the talker and the others should listen. If the stagebox is configured as described then the mixer is the talker and the stagebox and the EarMix are the listeners.

But there could be another reason for sync problems: If more than one device in the network tries to send the network clock.

The network clock in the mixer can be set either to “internal” or “network stream” which means that the mixer accepts an incoming clock signal from the network instead of using the internal one.

So I tried what would happen when I set the network clock of the mixer to “network stream” and suddenly the dropouts were gone.

The only explanation might be that the stagebox sends out a network clock too, and when the mixer is set to “internal” then there is a collision situation.

When you work with mixing consoles and rackmixers you can set the console to “internal” and the rack mixers to “network stream”, and the problem will not appear. On the stagebox there is no possibility to switch off the internal network clock. This is different from the AVB-listener mode.

I switched the mixer to “network stream” and expected that it would not work. But I could listen to clear music for more than 50 minutes. Then two dropouts appeared. This might mean that the clock from the stagebox is not as stable as the clock signal from the mixer. Network operation with mixer and EarMix only (where the mixer sent the network clock) was without errors.

The next thought: The system runs with one stagebox and the mixer set to “network stream”. As soon you add a second stagebox to handle more channels you will again have two devices in the network which send out a network clock which again will result in dropouts. I can't verify this at the moment but it seems to be logical. If you have two stageboxes and the mixer set to "internal" then there are three devices which send out the network clock at the same time in the same network. This might explain some reported effects.

Suggestion:

A firmware change is needed which disables the internal network clock in the stageboxes. The mixer should be the AVB talker and the only device which sends out a network clock signal.
0 votes
answered Sep 3 by wahlerstudios (82,900 points)
StudioLive_Series_III_AVB_Networking_Guide_EN_11092018

2.7.4 Clocking a PreSonus AVB Network

"Within the PreSonus AVB ecosystem, a StudioLive Series III mixer must be used the master word clock for the network. For some devices, clocking is handled automatically. (...) NSB-Series stage boxes are designed to provide both remote inputs and remote outputs for StudioLive Series III mixers. Like the EarMix 16M, the NSB-series stage boxes will default to external clock and sync to a StudioLive Series III mixer as soon as AVB sends are routed to their outputs. It is important to note that these AVB sends must be routed whether they are needed or not."

I understand this the way that the SL 16 MUST be set to "Internal" in "Network Stream".
0 votes
answered Sep 3 by wahlerstudios (82,900 points)
There could be one more thing to check: Connect the EarMixers and the stagebox(es) via their internal AVB switches. Does that make a difference to the connections via SW5E?
0 votes
answered Sep 4 by juergenboehme (450 points)
Well, we have something here which can’t be solved by changing a user setting or using the internal AVB switches instead the SW5E.

The lowest level is to connect the mixer directly with one network cable to one single stagebox or one single EarMix. When you connect an EarMix everything is fine. When you connect a stagebox there are dropouts.

The user can plugin a cable in the devices, and he can set some parameters in the configuration. The problem here is on a level where the user has no access. It is in the electronic communication between the devices after the user has done the cabling and configuration.

Yes, in general you are right. When the SL16 is set to “internal” the system should work. But it does not.

 “Like the EarMix 16M, the NSB-series stage boxes will default to external clock”. Even though it is written here, this seems to be not the case. It looks like the NSB-series stage box stays at internal clock even though the mixer is present in the network and the AVB sends are routed to their outputs.

This means the stagebox doesn’t recognize that she should use the available clock of the mixer and stays with her own internal clock instead.

There is an indicator for this. Besides the clock selector in the mixer screen there is a green light (which sometimes switches to red) when a stagebox is connected. This indicator is completely dark when an Earmix is connected. This seems to mean that there is an external clock signal coming in when a stagebox is connected.

I need to discuss this with somebody from the Presonus network technology department please. How can I get a contact?

By the way, are you in Germany? It’s complicated to explain this here in written form. Could we have a phone call for better understanding?
0 votes
answered Sep 4 by wahlerstudios (82,900 points)
Yes, I am living in Siegen/NRW, but I am no developer or technician, just a normal user/musician. It was important to have this conversation in English, because people all over the world are reading "Answers". I asked Jonny Doyle from PreSonus Support in Ireland to continue the subject. I have read somewhere that PreSonus is working on the NSB problems, but there is no information how far that is and when we as users will see a reliable solution. There ARE many posts and threads everywhwere about dropout problems with the NSB stageboxes...!

I am a happy "no NSB user" and for SL 16, 32R, 16R, three 16M and a SW5E used in any combination I can say everything works perfect!
...