Questions & Answers

Unable to Create Support Tickets

+5 votes
198 views
asked Oct 9, 2019 in Customer Account Portal by samarcher1 (260 points)

I'm unable to open support tickets on the my.presonus site.  I can fill in all the ticket info and press "Save" but nothing happens, and no ticket is shown as created.

(My root problem is that I'm unable to register the new hardware I just purchased because

https://my.presonus.com/publicapi/products/register_hardware

is returning "504 GATEWAY_TIMEOUT".

9 Answers

+1 vote
answered Oct 10, 2019 by samarcher1 (260 points)
selected Oct 18, 2019 by samarcher1
 
Best answer
Contacted support by phone and they confirmed they are aware of "some server issues" that may be causing support ticket and product registration trouble.  Said if you need products registered or support tickets created you could call them by phone and they can do either for you.

Edit: It sounds like people are still having issues with this, but I'm going to accept this as the answer for now since calling them directly appears to be the only way to register a product or create tickets.  (Come on, PreSonus, get your support site together!)
0 votes
answered Oct 9, 2019 by nathancopeland (150 points)
I am also not able to open support tickets....
0 votes
answered Oct 10, 2019 by dassoun (220 points)
Hello!
I will try to open a ticket for you, asking a technician to come and read your post.

Regards,

Julien
0 votes
answered Oct 10, 2019 by alexgiordano (280 points)
I have the same problem
0 votes
answered Oct 18, 2019 by willbradford1 (140 points)
I am have the SAME set of problems.  Have you gotten a solution to either the Registration or the problem creating a support ticket?
0 votes
answered Oct 19, 2019 by natashacorrigan (160 points)
same issues! ordered the audiobox itwo studio and tried to register it but it wont. then tried to contact support and cant do that either. im in the uk and cant seem to find a uk support number either. nightmare
0 votes
answered Oct 27, 2019 by rhondastraw (200 points)
Same issue. I'll call them tomorrow.
0 votes
answered Oct 29, 2019 by johnli2 (140 points)
Hey all. This mightn't work for all of you, but I did just have some luck with signing out and signing in again.
0 votes
answered Dec 20, 2019 by miroslavmeduri (180 points)
I am trying to create a ticket for two days now. I need support because the Studio one  4 Artist Oem version that came with Yeti Blue isn't loading the Isotope Ozone Elements. It has Locations disabled, but it should Read the VST3 folder and recignize it automatically. Very frustrating. I have managed to register Studio One, but that's it.
...