Questions & Answers

How to fix gain staging with input monitoring for live streaming

0 votes
431 views
asked Apr 10, 2020 in Studio One 4 by noreaction (130 points)

Hello, I have searched the forums and I find no clarity, but I can’t imagine I would be the only one who has to deal with this problem. Let me explain what I want to do and what is happening to not allow that. 

I have a windows 10 PC which is running an i9 CPU with a 1080 GTX founders edition and 128 gigs of ram. I want to be able to stream audio out of my 64 bit Studio One 4.5 professional song session master outs into OBS Studio v. 25 to be able to live stream to the Internet with great audio mixes of various live performances. I was not able to output from studio one via voicemeeter banana or related software by the same programmers due to these programs completely changing my inputs and outputs when I designate S1 to use it as the audio engine. This defeats the purpose of using my inputs and outputs on my focusrite Scarlett 18i20 and the optical link to the focusrite octo pre dynamic hardware. I need those inputs to be able to set up a live mix in studio before I send it out to OBS studio. 

I found another solution: voxengo recorder, which is a 32 bit vst that can be dropped in anywhere in the signal chain as a plug-in. Since I use studio one 64 bit I have resorted to using a vst bridge to have voxengo recorder 32 bit vst in my S1 64 bit song session. The vst bridge I am using is called “jBridge” and it seems to work fine. I have dropped it on my master fader and set the output to multimedia extension which can then be selected as an input in OBS studio. My sample rate and bit depth across my focusrite hardware, my windows desktop audio, my settings in voxengo recorder, and in my focusrite software mixer, as well as the song session are all set to 24 bit 48k. For this reason I do not believe it to be a dithering problem. 

The problem is that when I route the audio via MME from voxengo recorder to OBS Studio, the noise floor is very high and dependent on the hardware gain set on my master gain on the Scarlett 18i20. Inside studio one I have all tracks record enabled and input monitoring set ON. Noise floor sits at around -45 to -40 dBFS with my hardware knob at like 35%, which is a comfortable listening level for me. I usually put my physical master gain set between 35-50%. The problem is that when I play something and it hits the meter on the master fader at -5 dBFS RMS and peaks at 0 dBFS, post meter fader monitoring says that it peaks at -35 dBFS with RMS level barely louder than the noise floor. And when I disengage input monitoring on a particular track, the track then immediately jumps up in gain by about 40 dB, which can be heard in the speakers, seen on the master out of S1, and seen on the input in OBS studio. Once the transient dies down however and the input monitoring remains off while still record enabled, I am not able to hear anything I am playing, which is expected. 

What I cannot figure out is first: why is the input monitoring outputting to the master fader so close to the noise floor? And also why when I disengage the input monitoring it immediately rises in volume to what the meter reflects? When I record a few bars of music I am able to play it back and send to OBS studio at the appropriate gain level, but what I intend is to send the mix live and not played back to sync with live video to stream in OBS already mixed coming out of studio one. 

Anybody who has gone through this or a similar situation please let me know your solution/work around. 

Thanks in advance

Please log in or register to answer this question.

...