Questions & Answers

I cannot install universal control

0 votes
937 views
asked Feb 13, 2016 in FireStudio Series by kagasonic (120 points)
mac mini 2010, 8 gb ram, 2,4 ghz, 500 gb ssd.

mac os 10.11

logic pro x

presonus firestudio project, universal control 173

I cannot install universal control on my mac. The process ends with an error message. After restarting the system, the program is actually in the applications folder, but it doesn't work. Of course, the computer doesn't see the device. i tried uninstalling and installing again.

1 Answer

+1 vote
answered Feb 13, 2016 by gadget69 (30,330 points)
Hi,

When you installed the software, was the FSP plugged in? Have you tried a different firewire cable? I would suggest starting a tech service ticket, that way you will get additional help in the event we can't help here.

By the looks of your specs you are at the toward minimum requirements for the software...The reason I asked about the install is the paragraph in the release notes suggesting that you install with unit disconnected, then plug it in.

https://pae-web.presonusmusic.com/downloads/products/release_notes/UC1.7.3ReleaseNotes.pdf

In the Knowledge base I found this:

http://support.presonus.com/entries/118308-FireStudio-Family-Why-is-the-Universal-Control-crashing-when-I-launch-it-

There are other potentially helpful articles in the knowledge base as well.

http://support.presonus.com/forums/20568911-Firestudio-Family

I spoke with a friend who also indicated he thought it was an install with the FSP connected, you'll need to do a complete MANUAL removal of the old software, and re-install with the device unplugged, THEN when prompted plug in the device.
...