Questions & Answers

Studio One fails to open Akai MPK Mini Mk II at startup when Google Chrome is open

0 votes
170 views
asked Jul 10, 2020 in Studio One 5 by robertsantiago5 (160 points)
Hi,

I have the Akai MPK Mini MK II keyboard controller. Whenever I have Google Chrome open and I start Studio One (either version 4 or 5) there is a message at startup with a red/white pirate flag that says: "Failed to open MPK Mini Mk II!". After that, the controller does no trigger any sound. If I close Google Chrome and then start Studio One, then everything works as expected (no failure message or pirate flags). Doing some research I found this suspect setting in Chrome: Settings/Privacy and Security/Additional Permissions/Midi Devices with the following two options (toggle):

1. Ask when a site wants to use system exclusive messages to access MIDI devices (recommended) => Enabled by default

2. Do not allow any sites to use system exclusive messages to access MIDI devices => Disabled by default

I tested both options and when Chrome is open, the MPK Mini always fails to open at startup in Studio One.

Has anyone seen this behavior and know how to correct it?

Thanks,

Robert

3 Answers

0 votes
answered Aug 22, 2020 by ivoryjacksoniii (220 points)
I just bought a mpk mini3 and have Studio One 5 artist...i installed all the software and was trying to set everything up..the first time when i opened it i heard sounds from the pad etc..fail at startup..went somewhere..came back and now when i open up studio one i get the red with white pirate thing saying Failed to open mpk mini 3 thing...trying to fix it but not sure whats up...i did have google chrome open at the time..closed it then closed my daw and then tried to re open it..same thing..error message..so idk what to do..have tried everything..
0 votes
answered Aug 22, 2020 by ivoryjacksoniii (220 points)
so i re started my computer..my daw was the first thing i opened..no error message..and i hear sounds thru my pads...so i just did some maneuvering around to see if it would do it again..i closed studio one out...i then said let me open Chrome(you tube)..opened Mpk mini software manager..to get to mpk program editor..thru that i opened program editor user guide...THEN i opened back up studio one and again the error message popped back up..it was the same stuff i had open before....??.....so one by one i messed around with those things and found out the problem is  something to do with opening the window for the Mpk mini program editor BEFORE! you open studio one on the computer...i capped before because it works fine while both are open at the same time...so yeah idk..
0 votes
answered Aug 22, 2020 by robertsantiago5 (160 points)
After I wrote about this issue I found that when I opened the demo of Bitwig 3 with Chrome open it also failed to load the MPK Mini, This time though the Bitwig error message mentioned that not enough memory was available to perform the operation. Then, between then and now (sorry I don't remember exactly when) there was a Windows 10 update that was supposed to fix Chrome's memory hogging issues. After that update I have never seen the error again. No matter how many Chrome Windows (or tabs) are open, Studio One 5 opens the MPK Mini correctly every time. Hope that helps.
...