Questions & Answers

Connection issue with Quantum 2 and Catalina 10.15.5

0 votes
84 views
asked Oct 12 in Thunderbolt - Quantum by christophertedesco (210 points)
Running a Mac mini 2018, 3.2, 6 core i7, Catalina 10.15.5, Quantum 2 interface, StarTech 3 - 2 adapter

I had no issues with the Quantum 2 until upgrading to Catalina.  I have followed instructions on uninstalling, reinstalling, restarting, etc.  I have been working with the most recent Universal Control released July 7, 2020.  One stumbling block is I am never given the chance to "allow" the new software to be installed, it appears to install without this step, but Universal Control does not find my device.  There is no security preferences pop up during or after installation or after a restart.  It is not recognized in the sound section of system preferences, and it does not show up on the thunderbolt section of system report.  Any help would be greatly appreciated.

2 Answers

0 votes
answered Oct 27 by connorguiberteau (23,180 points)
 
Best answer

Full video includes instructions incase the allow button is not visible. 

+1 vote
answered Nov 3 by christophertedesco (210 points)
edited Nov 3 by christophertedesco
Followed all of the video instructions, and does not work.  As I poke around forums, I'm not the only person with this issue.  I'm not missing, or not seeing, or not finding the 'allow' button, the issue is that the new software never gets flagged by Catalina.  A dialogue box never pops up.  So no warning comes up when installing, and when going into system preferences - privacy and security, there's no issue.  Nothing to allow, it simply doesn't detect it.  Universal Controller finishes the installation and gives a successful message, but it doesn't work.  The interface is not recognized as being plugged into a thunderbolt port.  It's a bug, it's been months, and there's no fix.  I got to use an $800 interface for 11 months and now have an $800 brick.  Using my back up Scarlett 2i2 daily.  Be better Presounus, this isn't an isolated problem.
...