Questions & Answers

MacOs Big Sur - Quantum 2 - Universal -Control - Thunderbolt not working

0 votes
asked Nov 28, 2020 in Thunderbolt - Quantum by haimari (1,190 points)

Worked fine with Catalina

Does not work with Big Sur.

In System report i see the below: (Apple Icon --> About this mac ---> System-Report)

Quantum 2:

  Vendor Name:    PreSonus Audio Electronics

  Device Name:    Quantum 2

  Vendor ID:    0x3C

  Device ID:    0x102

  Device Revision:    0x1

  UID:    0x003C20600044RTF

  Route String:    1

  Firmware Version:    25.2

  Port (Upstream):

  Status:    Device connected

  Link Status:    0x2

  Speed:    Up to 20 Gb/s x1

  Current Link Width:    0x2

  Cable Firmware Version:    1.0.16

  Cable Serial Number:    C4M82FJ7787E3333

  Link Controller Firmware Version:    0.14.0


  Status:    No device connected

  Link Status:    0x7

  Speed:    Up to 20 Gb/s x1

  Current Link Width:    0x1

  Link Controller Firmware Version:    0.14.0

3 Answers

+1 vote
answered Dec 9, 2020 by hamishmichael (520 points)
I am having the exact same problem. Have uninstalled and reinstalled all software and drivers. I'm running Big Sur on the new Apple silicon (not my choice, had to replace my MacBook and can't downgrade).

A little assistance would be greatly appreciated, PreSonus. Thanks!
0 votes
answered Jan 23, 2021 by kevinchang6 (150 points)
Having this issue as well, have any of you resolved this?  I’m on an Intel iMac, tried all the different procedures for unlocking security already.  Big Sur 11.1, when I try to download the UC pkg it says wrong OS.  Is that an issue?
0 votes
answered Apr 24, 2021 by charleswood2 (140 points)
I just bought the Studio 68c and I cannot get Universal Controller to work with Big Sur!  Very frustrating, I hope someone has an answer.