Questions & Answers

ASIO4ALL issues with Studio One 4

0 votes
asked Dec 17, 2020 in Studio One 4 by fabianfehl (220 points)
edited Dec 17, 2020 by fabianfehl

Hello everyone,

I recently searched for a solution so that I don't have to use Windows Audio drivers. Then I installed ASIO4ALL v2 driver. S1 reconizes it as an output and I can also set everything up etc. but when I start a session I have no Sound. My speakers are connected to my mainboard via an optical output (44.1khz->192khz) and when I launch the settings of asio4all, it shows me that my realtek SPIDF output is turned on, but I still have no signal. Only if I'm switching back to "Windows Audio" but then I have a conflict with my Input with my mixer wich I use for my microfone. its connected via USB and it only supports 48khz. so when I run S1 with windows audio driver (wich somehow only supports 44.1khz) the recording is unavailable. Thats Why I wanted to use ASIO4All. Can somebody help me with this issue?

EDIT: I took a screenshot and uploaded it here to show you my ASIO4All settings...

3 Answers

+1 vote
answered Dec 17, 2020 by wesleypeterson (20,870 points)
selected Dec 18, 2020 by fabianfehl
Best answer
ASIO4ALL is pretty buggy, but really useful (I'm not sure why PreSonus doesn't include a generic ASIO driver like Cubase does.) I would try unchecking  the 'Force WDM Driver to 16Bit" in yours it's "WDM-Triber immer mit...", your pics a little blurry so I can't read it well. The bottom right hand box.

In theory, you should be able to change to 48k in Windows10 by clicking the windows key and searching for 'control panel'  >  Sound > pick your speaker > click on properties > Advanced Tab > you should be able to change to 24bit 48k or many other options depending on your audio driver. If it's not listed there then you probably would want to check your audio driver in Device Manager and check if the manufacturer of the soundcard has an updated driver.
+1 vote
answered Dec 18, 2020 by fabianfehl (220 points)

Thanks for your help. But I solved it yesterday by myself.

Anyway: It‘s like you Said. I had to Turn on the complete Range from 44.1khz to 192khz. Cause everytime when I Start s1 and it Switches to an different Rate then my Digital Sound Receiver sais „unlock“. Means That the Output device (in this case my pc) had to unlock this Rate before Using it. Then I toggled the whole realtek in- and outputs to Asio and Sorted it in the s1 A/O Settings. After that I have output from Asio4all and Input from my usb Mixer. Everything is Fine Now
0 votes
answered Dec 18, 2020 by wesleypeterson (20,870 points)
That's great! Thanks for the update.