Questions & Answers

44.1 khz samplerate problem with StudioLive 32SX

0 votes
1,263 views
asked Dec 27, 2020 in StudioLive Series III by jrgpiringer (120 points)
when i switch my studiolive 32 sx (latest firmware 2.4.17466) to 44.1 khz it works with studio1 & capture.

but as soon as i switch the desk off and on again and try to use it on my mac with studio1 & capture the desk is reported as working on 48khz. although the setting in the mixer still says 44.1 khz. and consequently the sound of studio1 is heavily distorted (i guess: sample rate mismatch).

when i switch the desk to 48 khz and then back to 44.1 khz it works again with the correct sample rate and no distortion.

this is really annoying. do i have to change the sample rate on the desk all the time before i can use it with 44.1 khz? please fix that problem!

btw: universal control still reports 44.1 khz.

my macbook pro (15-inch, late 2016) runs on macOS Catalina 10.15.7

3 Answers

0 votes
answered Mar 5, 2021 by robcull (280 points)
Did you find a solution?

we have a similar issue with our StudioLive iii desk stating 44.1 but El Capitan sees it as 48 and you cant change it in the drop down menu (as there is no other choice) == so we cant use Logic X

So we're still using Lion and Logic9 .......
0 votes
answered Apr 13, 2023 by richiejarvis (170 points)
I am now having the same issue, happened out of nowhere and I can’t change it in settings or preferences. No matter what I do on the backend the MAC running Monterey still shows the console at 48 but at the console end it’s at 44.1

I am at the point I will just buy Logic.
0 votes
answered Apr 21, 2023 by bernardbeaumont (150 points)
Same here SL32 at 44.1Khz but Universal control sees 48Khz and no connection to Studio One6.

I had to install '' ASIO4ALL'' as sound card in SO6 and run SL32 in ''compatibility mode '' to resolve the problem. Bug started after update of firmware beginning of april.
...