Questions & Answers

Glide Roli Seaboard Rise

+2 votes
446 views
asked Sep 23, 2021 in Studio One 5 by willstar.reeves (530 points)
I have a seaboard rise set to MPE mode but glide does not work. Thought this was happening:

All notes on all midi channels are received and passed on to the VST. All controller information, including pitch, seemed to be merged to channel 1 only (with the exception of aftertouch/pressure). I originally thought this because the midi monitor shows me all the data and the only way of getting "glide" to be recognised is to configure the seaboard to "single channel mode".

When in "single channel mode " and it set to channel 1, everything works and is recorded; notes, glide, slide, press, etc. If I change the "single channel mode" to channel 2, only the note and press work - in the same way as "MPE mode fails".

However, I checked this hypothesis with a "dumb" piano controller.  With the controller set to channel 1 pitch bend worked.  With the controller set to channel 2, pitch bend still works- so pitch bend data isn't being merged to channel 1 after all!  So it seems as if the problem is specific to the Seaboard or maybe "MPE mode" in the midi controller setup?

I also read there are some issues with VST3s and Studio One so perhaps this is the issue (I'm trying to use Equator 2 VST which I believe is only available as a VST3).

I'll do some further investigation but tech support said they can't help as they don't have Roli hardware.  Anyone out there with a seaboard having a similar issue with version Studio One 5 (Windows 10 x64)?  Or anyone have any ideas?

I should add that I'm only a hobbyist musician and a newbie when it comes to Presonus, but I've used Reaper a fair bit where I cannot reproduce this issue.  Interestingly though, I have tried Ableton 11 and it does seem to have similar issues!

Any advice would be much appreciated!

1 Answer

0 votes
answered Sep 28, 2021 by willstar.reeves (530 points)

A kind user on the Forum solved this for me!  I was being an idiot and didn't realise that you have to set the VST to "Enable MPE" as well as the input device itself.  Thanks very much to @sintil8!

Enable MPE control over VSTs, check this option.

...