Questions & Answers

After PC restarts, Stream Mixes in Universal Control don't work correctly until I mute/unmute a track

+3 votes
679 views
asked Mar 28, 2022 in Revelator Series by njglover (180 points)
edited Mar 29, 2022 by njglover

I'm using the Revelator io44, but there doesn't seem to be a category for that yet. At any rate, whenever I turn on my computer, the stream mixes don't behave as expected. I use them in conjunction with OBS to record things, but I find that when I go to do so, the stream mix channel in OBS is showing levels for my mic input (over XLR) but not for playback. However, I have the mic muted and the fader turned all the way down whereas the playback is at unity and not muted, so I should be getting playback and no mic at all. I have to unmute the mic track to get it to output correctly, after which point I can mute it again and everything works correctly. It seems like it just doesn't respect the settings I have saved until I interact with it in some way. I don't otherwise have any reason to open the mix panel, so it's frustrating to have to open it just to get it to work correctly. Whatever settings I have in the various mixes should be respected without me having to open the program (provided that it is set to run at startup and is running in the background, as it is for me). These steps should reproduce the problem:

  1. In OBS, go to Settings > Audio and set the first mic input to Stream Mix A and the second one to Mic 1/2. You may not need to set the second input, but that's how I have it set, so I'm including it here for posterity.
  2. In the Revelator io44 UC mixer, open Stream Mix A and turn the mic input all the way down and mute it. If it's not already there, set the Playback fader to 0 dB. For the main mix, leave the mic and playback unmuted and set both to 0 dB.
  3. Play back some audio and talk into the mic. In OBS, you should see that the levels you set are correctly reflected in the OBS meters. That is, you should be getting your mic on the second channel and only playback on the first.
  4. Turn the computer off and back on (restarting may not have the same effect, so make sure to turn it off and then back on). Once everything is loaded up, open OBS again. As before, talk into the mic. You should see that your mic is registering on the first channel even though it should be muted there. Play back some audio and see that it is not registered in the first channel even though it is not muted there.
  5. Open up the Revelator io44 UC mixer and go to Stream Mix A. Unmute the mic and mute it again. Check the levels in OBS and see that everything is working correctly now.
Note that this happens for each stream mix. That is, I have to unmute/mute something in Stream Mix A to get that one working, then unmute/mute something in Stream Mix B to get that one working. While I don't use both at the same time, I could see this being extra frustrating for someone who does.

Please log in or register to answer this question.

...