Questions & Answers

How do I assign the fader knob on my AKAIMPD18

0 votes
asked Jun 6, 2017 in Studio One 3 by nickpovey1 (150 points)

So I have an akai mpd18 and I want to assign the fader to my volume fader so I can do live volume automations. 

I looked up some tutorials and they all say all I have to do is tweak the fader in studio one and then the fader on my mpd and do alt m to link the 2. This does not work for me. I have tried every combination and order I can think of to no avail.

As far as I know my mpd is set up correctly in external devices. Here are some screen shots. Studio one definitely seems to know the fader is being tweaked on my mpd as it is showing up in the midi monitor. The pads work fine and always have.

I have screen shotted everything I can think of that might be relevant.

Toshiba P 50 C18K

Windows 10 (64 bit) Home version 10.0.14393

Studio one  professional

1 Answer

0 votes
answered Jun 9, 2017 by Jamesrhone1 (200,330 points)
Best answer

Sorry to hear about the recent issues you have been experiencing.

Here is a guide from Akai on setting up their devices with Studio One:

Basically you will need to create a "New Keyboard" in Options/Preferences(OSX) > External Devices. This will be for the drum pads. Make sure in this New Keyboard to not place check marks by any of the filters. This will disable the ability for this device to send certain MIDI messages.

Then create a New Control Surface for the surface controls of the unit. 

Here is another great article in that regard:

If you have further need for discussion on this issue, please submit a support ticket. 

We also encourage you to create a thread about this on the Presonus user forum. This will allow for back and forth discussions about an issue or question and more points of view as to possible different approaches or workflows.