Questions & Answers

Can’t update Firware from version 7794 to any newer version on RM16AI

0 votes
asked Oct 3, 2017 in Ai Mixers by RichStudio (200 points)
edited Oct 3, 2017 by RichStudio
I have tried to update the firmware on my RM16AI. The process starts, gets to the solid green light status, hangs for a bit.

Then I get “network updated failed. Power cycle mixer” I do this, restart UC and see that the firmware is still version 7794.

I have tried updating using my iPad connected via router & with the mixer connected directly to FireWire to my Mac.

The Mac is connected to the internet.

I used the USB method and still received the network error. Also received the network error when the mixer was connected to the dedicated router (no internet) that I use with my iPad Pro.

Any help is appreciated.


1 Answer

0 votes
answered Oct 3, 2017 by Michael Martin (89,010 points)
Best answer

In situations where network updating isn't working or available, you will need to follow another update method.

Use the following KB article to upgrade the RM via USB Flash drive: Click here

If you have any issues, submit a support ticket to Technical Support for further troubleshooting.

asked Oct 3, 2017 in Ai Mixers by RichStudio (200 points) Firmware update