Questions & Answers

Audio Preview Behavior

0 votes
119 views
asked Nov 26, 2017 in Studio One 3 by fhhowdy (160 points)
edited Dec 3, 2017 by fhhowdy
I've noticed that SO3 has a rather annoying behavior of making a multitrack recording, and then, no matter how long I wait, or what combination of saving and waiting I perform, if I close SO3 and to mix the song later, only 2-5 of my audio previews (waveforms) actually save...which means I have to wait about 5 minutes for them to regenerate.  Once they re-generate, I have no issues with them disappearing again -- it's just during the initial record.  I'm typically doing mulit-tracks with around 20-31 channels, and attempting to go ahead and mix with the waveform previews generating causes drop-outs.  

My setup when doing these is with a Macbook Pro (2015) with an external USB3 hard drive.   Outside of this, I have no other issues with SO3 (minus my request to be able to quickly split a "song" into multiple songs from SO3, like we can from Capture -- which doesn't work on our massive dante network.

Thanks!

------

Please be sure to read my question -- this is not about generating the previews or performance on the USB drive.  I've been doing this for three years, and I've NEVER had a problem with the performance of the USB system.  I tend to edit with a thunderbolt RAID array, but utilizing the USB drive is not a problem here.  It is possible that the performance of the USB drive is causing the drop-outs while it's trying to generate the waveforms, but I'm even seeing this on a massively performant RAID array, if I copy my project over.  But, I didn't want to add an element of change that could be contributing to the real issue I'm trying to discuss.

The specific issue is about the previews, which are generated correctly (instantaneously) when I record, not saving.  Once I stop the recording, all of the waveforms are visible.  At that time, I can save and resave the project to my heart's content, but no matter how many times I do that, nor how long I wait before or after saving it, if I close SO3, when I re-open the project file, it wants to re-generate about 2/3-3/4 of my waveforms.  Why?  What can I do to ensure that SO3 doesn't delete the cache or whatever it's doing to destroy the generated waveform previews?

1 Answer

–1 vote
answered Nov 27, 2017 by diapasonprodues (2,510 points)
I always record multi-track and have absolutely never even noticed any wait time at all for waveforms to generate. It is always instantaneous. Plus if waveform preview being generated causes audio dropouts for you that's another reason for me to believe there is some issue with read/write from your USB external drive. Have you benchmarked it to test if it is performing fast enough to record and playback that many channels at whatever resolution you're using with overhead to spare?
I don't think it is generally a good idea to record or mix from an USB external drive anyway.
...