Questions & Answers

How do I troubleshoot my UCNet connection with my StudioLive Series III for DAW Mode to work correctly?

+2 votes
2,822 views
asked Jan 18, 2018 in StudioLive Series III by AlexTinsley (773,130 points)
I've seen a lot of people like myself having trouble getting my StudioLive Series III to work with DAW mode, what can I check to make sure it's making the proper connection?

4 Answers

+1 vote
answered Jan 18, 2018 by AlexTinsley (773,130 points)
selected Jan 18, 2018 by AlexTinsley
 
Best answer

A problem that too many have is that the Mixer is on one network and the computer is on another network. 

The simplest answer is found on page 90 in the StudioLive Series III Owner's Manual

To begin using your StudioLive Series III mixer as a controller for Studio One, connect it to an available Ethernet port on the same router
to which your computer is connected (wired or wirelessly). 

Troubleshooting UCNET: 

To troubleshoot the connection we have to check to make sure UCNET is on the same subnet as the device it is going to control.

We can do this by checking your Studio One.log to confirm what is occurring.

Step 1: Open the Settings Folder. 

On the Tool Bar in the Help menu is an option for "Open Settings Folder"

Then find the file that says "Studio One.log"

Step 2: Opening the Log File

Now you may need to close Studio One because it uses the Log file while the application is open. 

Close Studio One without closing your file manager window. 

With Studio One closed, double click Studio One.log it to Open it 

Side Note: Windows will use Notepad to open it. Mac will use TextEdit to open it. 

Step 3: Finding the error

With the log file open, look for UCNET lines. Look for a time out with two different IP addresses.

This is an example of a failure.

NOTE: The issue here is that the subnets do not match. 

The mixer is on 10.0.0.19 while Studio One computer acting as the remote client is on 192.168.1.3. 

Since they are not on the same subnet, there is a timeout as it can't connect. 

NOTE: These need to be on the same network

The same network is indicated by the first 3 decimal separated numbers, these are the numbers that need to match.

Here is an example of a correct match. 

This is a screenshot from the StudioLive Series III LCD window and it shows Control Network for the Mixer and the Remote client are on the same subnet, 

Looking back at the Studio One.log we can now see that there is a successful connection between the mixer and the remote Studio One client as they are on the same network and subnets. (ie first three sets of decimal separated numbers) 

Your network addresses may be a different set of numbers, the network addresses shown here are just to show as an example. 


You might be asking how do you make sure the two networks are the same? 

Go back to the top of this article to see how to properly configure your setup and in the manual, you can go to read how to do that. 

Studio One checklist:

  1. Options/General/Networking: Verify Allow remote control apps to discover the DAW is Enabled
  2. Options/Advanced/Service: Verify remote control support is Enabled
  3. For Windows, verify that you are running Studio One as Administrator.  

Router Check List:

  1. Recommended routers. https://support.presonus.com/hc/en-us/articles/210047813
  2. DCHP is needed for this to work.
  3. Check your hardware router is not blocking port 47809
  4. Check that your Firewall is not blocking port 47809
  5. "If you are running Windows 10 Pro and having network issues, be sure to check if the Hyper V feature is installed on the PC running Studio One. If so, uninstall it or look for alternate solutions as virtual networking can be the root cause of your problem."

Using Different IP Modes (from StudioLive™ Software Library Reference Manual 5.7.4)

In the Control Network area of the UCNET screen, you’ll see the current IP address of your StudioLive. This IP address can be assigned in one of three ways. Select the necessary IP assignment mode by touching one of the following buttons:

  • Dynamic. The IP address is assigned automatically upon connection to the network and can shift to a new address when necessary due to changes in network availability. In this mode, a Renew button is shown onscreen. Touch this button to renew the DHCP lease for your StudioLive.
  • Static Self (Self-Assigned). The IP address is assigned automatically but stays the same thereafter until you need to change it. In this mode, an Apply button is shown. Touch this button to auto-assign a new static IP address to your StudioLive.
  • Static Manual. The IP address can be set manually and remains the same until it is changed. In this mode, an Edit button is shown. Touch this button to open the Static Manual Edit screen, where you can specify IP address, subnet mask, and gateway settings for your StudioLive as needed for your network configuration. Touch each field in the form to bring up an onscreen keyboard for entry. When you’re finished entering the settings, press Apply to establish the new settings. To exit without re-setting IP settings, touch the Cancel button.

Dynamic Mode. This is the default setting for StudioLive mixers and is the most common way you will use your mixer on a network. In Dynamic IP mode, the mixer is assigned an IP address by a DHCP server. Because of this, Dynamic IP mode requires that your StudioLive be connected to a network that also has a router connected. In this mode, your mixer will request an IP address from the DHCP server when it is powered on. The DHCP server will then answers and assign the mixer a unique IP address. The mixer will continue to send and wait for an answer to its DHCP requests.

Static Self-Assigned Mode. When two network devices are directly connected to each other or a switch, rather than to a network router, they cannot have their IP addresses assigned dynamically. In this case, the devices must be able to self-assign their own IP addresses.

The most common direct Ethernet connection scenario is while using a StudioLive AI console mixer with a StudioLive RM/RML mixer in Stagebox mode or to connect your Windows Touch computer directly to your StudioLive mixer to run UC Surface wired, rather than wirelessly.

In this mode the mixer will automatically assign itself an IP address in the 169.254.0.0/16 range, allowing connection with other devices in the same IP address range.

Static Manual Mode. This mode is typically reserved for more complex networking installations or situations that otherwise require setting static IP addresses. In this mode, you can manually assign an IP address, subnet mask, and gateway. If you’re not sure how to manually configure static IP address assignments, please consult your IT administrator before attempting to configure your StudioLive mixer in Static Manual IP Address mode. Unless you have a specific need for static IP address assignment, most users would be advised to use Dynamic mode and let IP addressing be handled automatically by your router/network DHCP server.

Power User Tip: Network modes are not intended to be changed on the fly. To ensure proper network configuration and connection, always power cycle your StudioLive mixer after changing its IP assignment mode.

0 votes
answered Jan 20, 2018 by fly5mike (280 points)
I just went from the board to my pc,no router
0 votes
answered Jan 22, 2018 by tommiller9 (240 points)
edited Jan 24, 2018 by tommiller9

For all of you Windows 10 users (possibly other versions too...)

If you go through the steps in the accepted answer and can't figure out why your console is on one network and Studio One 3 is connecting to another, try one of the following:

  1. The quick and dirty:
    • Open your Network and Internet Settings control panel
    • Click on Ethernet on the left side navigation 
    • Under Related Settings (on the right), click on Change adapter options
    • In the Network Connections window, look to see if there is an entry for vEthernet (Default Switch)
      • If there is, right-click on it and select Disable
        • ​Doing this causes the adapter your computer is actually using to connect to your network to route internet traffic--again, a relatively transparent operation to the end user
  2. ​Essentially the same as #1, but walk through the steps in the accepted answer to see what network UCNET is binding to, then open a command shell window and run ipconfig to locate the adapter that is listed in the S1 log file--chances are it is vEthernet; if not, then you will need additional troubleshooting to sort out what your scenario is.

Apparently, there was a fairly recent update that implemented this as the default network adapter that is used to route internet traffic through. According to the lead Studio One dev, S1 binds UCNET to the network adapter that is connected to the internet, which after the recent Win10 update, happens to be vEthernet, which is on a completely different IP network than the router your computer is connected to (Windows does some sort of internal routing to make it transparent to the end user). 

I disabled this adapter, restarted Studio One 3, and my StudioLive 32 is now seeing S1. 

UPDATE: When you restart Windows 10, and have the vEthernet adapter disabled, a new one will be created by the OS. So, you will have to go and disable this again. This is very inconvenient--it would be a good idea for Studio One to provide the option to select/set the (default) network connection that UCNET binds to when is starts up.

If you need this adapter for other applications, like running VMs, etc...just make sure to re-enable the adapter after you're done with S1 :-)

YMMV, but this worked for me.

Hope this helps!

Tom

+3 votes
answered Feb 28 by chazguitar (310 points)
I am still not fully connected.  From my limited knowledge of TCP/IP, it seems that if a good network connection exists between PC and Series 3, and S1 is still not showing up in the UCNET (yet UC controls mixer ok) than the connectivity problem is software related, not IP related.

I have a good network connection, i.e.,  can ping the mixer from the PC, and they both show up with addresses that are one digit apart. I even changed things up to assign a static IP to the board and computer, with and without a router (using a crossover cable).  The log file shows communication happening with 192.168.1.2 and .3 (pc and mixer) ONLY, so I'm confident that I have a good network connection.

Still, nothing in the UCNET window besides the default Mackie and HUI.  I'll try a different router and/or connecting PC by wifi, but I'm not confident that the problem isn't somewhere else.  Thanks for any thoughts.
...