Questions & Answers


+3 votes
asked Feb 27, 2018 in AudioBox USB by kevinbelaen (150 points)
Ok here's the deal...My AudioBox USB96 works perfectly on my laptop as long as I make sure that I plug my AudioBox into the same USB port that the driver was originally installed on (ANNOYING but I guess that's just the way it is....).

This youtube video explains exactly my situation;

Here's the problem with my desktop....I CANNOT use the USB port that the AudioBox driver was originally installed on.

The reason I am NOT able to use that USB port is because I found out after the fact (after installing the audiobox driver) that ALL my USB3.0 ports on my desktop are not compatible with my AudioBox USB96. I just so happened to install the Audiobox driver on one of my USB3.0 ports :(

When the AudioBox is plugged into one of the USB3.0 ports, all I see is flickering for the AudioBox sound device when I hover over the sound icon on my taskbar. When the AudioBox is plugged into one of my USB2.0 Ports, the AudioBox sound device does not flicker....I am actually able to select it as my sound device (I hear no sound though of course since these dumb audioboxes need to be plugged into their original USB port as I have specified up top). may ask.....    "Why don't you just uninstall all the AudioBox drivers/files then reinstall on one of the USB2.0 ports?"

Well, I tried that.....probably more times than I should have..... The AudioBox would work SOMETIMES for a few minutes but it would always cut out and then stay that way. I found no concrete way of getting this **** thing to work. I am so feed up with Presonus....

Anyone have any suggestions? I tried looking online for ways to perhaps convert USB3.0 ports to USB2.0 ports but have had no luck.

The motherboard I am using is a  GA-AB350-Gaming 3 motherboard.

Thank you and have a great day!


8 Answers

+3 votes
answered Nov 1, 2018 by raphalgrana (290 points)

I have a simillar problem, it only works on one of my usb 3 ports, which is a bummer.

I have an AMD ryzen 7 2700x and a rog Crosshair VII hero motherboard.

Apparently Presonus couldn't be less bothered since this post dates from feburary... no response. 

It took them 4 days to moderate one of my answers, so I'm not that surprised.

I won't be buying any of their products in the future.

+3 votes
answered Apr 17, 2019 by rzasomuncu (220 points)

I have that same problem

my motherboard asus tuf b450 gaming, cpu amd ryzen 5 2600

usb 3.0 port on problem, unstable, inconsistent

If the USB 2.0 device does not recognize, device's LED is lit but there is no device in Windows

Is this problem caused by motherboard related audiobox related?

if the problem is from the audiobox what is presonus thinking ?
asked Apr 7, 2020 in AudioBox USB by tyykoturkka (120 points) Exactly the same setup
0 votes
answered Nov 15, 2019 by milowork (230 points)

I'm using GA-AB350M-Gaming 3 motherboard. USB3.1, USB3.0 and USB2.0 is both unusable.

The USB 96 works fine with my older computer (A 55 chipset).

I'm buying a PCI-E to USB 2.0 card.

0 votes
answered Mar 16, 2020 by samuelcouture (190 points)
Exact same issue here! Looks like it's possibly AMD chipsets that are the issue? I'm not sure but let's hope they realize that this is an issue and it gets resolved!!!
0 votes
answered May 27, 2020 by tylernewberry1 (140 points)
Same here, over TWO YEARS later. Anyone figure this out? Why is PreSonus ignoring this?
MSI B450 Carbon Pro Gaming AC - Ryzen 7 2700X
0 votes
answered Dec 15, 2020 by hrvojejuri (140 points)
I have been using my AudioBox USB 96 for quite a while (about a year and a half) on my old PC with an Intel chipset (which took forever to properly set up...) and now it doesn't work on any USB port on my new computer with an AMD chipset. The USB 2.0 ports seem to disconnect and reconnect it constantly and the USB 3.0 ports seem to work when I connect it, but I can't get any audio from it. If this doesn't get fixed soon I will be forced to switch to another audio interface.
0 votes
answered Feb 27, 2021 by rossbaldwin2 (140 points)
edited Feb 27, 2021 by rossbaldwin2

Update (like an hour later): Found someone in another thread who had a workable solution, but the hoop jumping seems ridiculous for a product that should work out of the box. I'll be returning mine and getting an audio interface that plays nicer with Windows I suppose.
Thread here is the same as the one linked to the text above: <>

Feb 2021 here, and it seems I am having the exact. same. issue. as ya'll have described. I'll quote @hrvojejuri (with some minor adjustments) to describe my issue:

"[Windows 10 user]...the USB 2.0 port, [sadly I only have one on my current rig,] seems to disconnect and reconnect the Presonus 96 constantly and the USB 3.0 ports seem to work when I connect it, but I can't get any audio from it. If this doesn't get fixed soon I will be forced to switch to another audio interface."

Emphasis added, but sadly it's true. I was so amped to start a podcast with my buddy, and this is a real bummer to have a product not working and its manufacturer seemingly unable to help. I'll post back if I can get anything to work.

0 votes
answered Mar 21, 2021 by nealwaller (160 points)
I also am having similar problem with New Mack Book with UBS3 ports Type C. Can only get playback but can not get input to connect to studio one 5... The only reason I bought a brand new Mac book pro was for sphere, had no idea that this would be an issue. Very upset!!!!!