Questions & Answers

USB PORT PROBLEM: AUDIOBOX USB96 WILL NOT WORK WITH MY DESKTOP USB PORTS, WORKS FINE WITH MY LAPTOP

+1 vote
964 views
asked Feb 27, 2018 in AudioBox USB by kevinbelaen (130 points)
Ok here's the deal...My AudioBox USB96 works perfectly on my laptop as long as I make sure that I plug my AudioBox into the same USB port that the driver was originally installed on (ANNOYING but I guess that's just the way it is....).

This youtube video explains exactly my situation;

Here's the problem with my desktop....I CANNOT use the USB port that the AudioBox driver was originally installed on.

The reason I am NOT able to use that USB port is because I found out after the fact (after installing the audiobox driver) that ALL my USB3.0 ports on my desktop are not compatible with my AudioBox USB96. I just so happened to install the Audiobox driver on one of my USB3.0 ports :(

When the AudioBox is plugged into one of the USB3.0 ports, all I see is flickering for the AudioBox sound device when I hover over the sound icon on my taskbar. When the AudioBox is plugged into one of my USB2.0 Ports, the AudioBox sound device does not flicker....I am actually able to select it as my sound device (I hear no sound though of course since these dumb audioboxes need to be plugged into their original USB port as I have specified up top).

So....you may ask.....    "Why don't you just uninstall all the AudioBox drivers/files then reinstall on one of the USB2.0 ports?"

Well, I tried that.....probably more times than I should have..... The AudioBox would work SOMETIMES for a few minutes but it would always cut out and then stay that way. I found no concrete way of getting this **** thing to work. I am so feed up with Presonus....

Anyone have any suggestions? I tried looking online for ways to perhaps convert USB3.0 ports to USB2.0 ports but have had no luck.

The motherboard I am using is a  GA-AB350-Gaming 3 motherboard.

Thank you and have a great day!

-Kevin

2 Answers

+1 vote
answered Nov 1, 2018 by raphalgrana (250 points)

I have a simillar problem, it only works on one of my usb 3 ports, which is a bummer.

I have an AMD ryzen 7 2700x and a rog Crosshair VII hero motherboard.

Apparently Presonus couldn't be less bothered since this post dates from feburary... no response. 

It took them 4 days to moderate one of my answers, so I'm not that surprised.

I won't be buying any of their products in the future.

0 votes
answered Apr 17 by rzasomuncu (160 points)
Hi,

I have that same problem

my motherboard asus tuf b450 gaming, cpu amd ryzen 5 2600

usb 3.0 port on problem, unstable, inconsistent

If the USB 2.0 device does not recognize, device's LED is lit but there is no device in Windows

Is this problem caused by motherboard related audiobox related?

if the problem is from the audiobox what is presonus thinking ?
...