Questions & Answers

Studio 192 Mobile Won't Work after Updating Firmware - Released on September 13, 2018

+11 votes
1,025 views
asked Sep 19, 2018 in Studio 192 USB 3.0 Interfaces by prock (720 points)
reshown Sep 19, 2018 by brianmeisner1

OK...  I recently updated the UC to version 2.9.0.49213 which offered a firmware update.  After checking what the firmware update improved, I decided to update to take advantage of the retention of the 48v power setting.  Apparently the update failed and now I am stuck with a non-working audio interface.

I am in contact with Presonus technical support on this but, the back and forth communication is very very slow. Painfully slow!  On their suggestion I reverted back to UC version 2.8.0.48221 to get the "Update Anyways" option.  I even installed older versions of UC (1.5, 1.8, & 2.4) to try and get that "Update Anyways" option.  So far that option has not appeared.

The last thing I tried per tech support instructions was to manually remove the 192 from my Win 10 PC (with the latest updates) completely in device manager.  The 192 was reinstalled with UC version 2.8 and the connection was moved to a USB 2 port.  Still no "Update Anyways" option is presented.

So...  day (4) without a fix.

Does the forum have any other thoughts, ideas, suggestions for how to get this baby working again?  I appreciate the Presonus technical support but, it really is way too slow going back and forth through the support ticket system (like emails).  I wish they had telephone support so I could get this fixed or, at least know if this is going to need repair, or if it is bricked forever.  Thank you.

Regards  cool

5 Answers

+3 votes
answered Sep 19, 2018 by cory baker (710 points)
I wish I had an answer. I have been struggling with this for a week. I have tried every option under the sun. The support people have tried to be useful, but it seems that they dont completely understand the problem any more than I do. I have been told repeatedly to "update anyway" when that is not an option. It doesn't matter what version of UC I install. It is beyond frustrating. I paid $600 for the Mobile 192 and I make 15 bucks and hour. I cannot fathom how someone who uses this in a professional setting must feel. Regardless, we need phone support for this kind of thing. What is worse is there was an email I got from PreSonus about a service that specializes in tech support for all things DAW related, but I lost it. I would have paid $100 rather than wasting the last week trying to get this to work. I am sick to death of uninstalling drivers, UC and restarting. This thing worked like a dream before. It is clearly YOUR update that did this. Please for the love of God fix it.
+2 votes
answered Sep 19, 2018 by prock (720 points)

FYI... more discussion on this issue is on the forum...

https://forums.presonus.com/viewtopic.php?f=232&t=31765

Regards  cool

0 votes
answered Sep 24, 2018 by Skip Jones (158,970 points)
selected Sep 24, 2018 by Skip Jones
 
Best answer
Please open a support ticket with Presonus.

Skip
0 votes
answered Sep 26, 2018 by prock (720 points)

Yes... please submit a support request ticket with PreSonus as soon as you can.  My issue with this has been fixed to my satisfaction.

Regards  cool 

0 votes
answered Sep 26, 2018 by fernandolavaselli (240 points)
Hi :( Im having the same problem... already talking with the support people, but they give me programmer guides to make it work again... this is very sad for me. They make this trouble with the firmware update and now pretend that all have to do with my system. I hope some day my new paper holder become an audio hardware again... I live far away US and Europe to pay the same price for a new one, I dont going to do that. Bye!
...