Questions & Answers

Universal Control doesn't show my Faderport 8!

0 votes
197 views
asked Sep 11 in FaderPort 8 by brianschaffner (150 points)
I recently purchased a used Faderport 8... but it has old firmware on it. I tried to use Universal Control to update the firmware, but the Faderport 8 does not show up as a device. Using MacBook Pro with High Sierra.

Also - the Faderport does work with my DAW, but I wanted to get the latest firmware on the unit. So I know the device isn't bad... but I don't know why Universal Control doesn't see it. And, in checking the OSX System Report, it shows the Faderport connected via USB.

Thanks.

2 Answers

0 votes
answered Sep 11 by AlexTinsley (731,220 points)
 
Best answer
Make sure you're using the latest version of Universal Control for FaderPort 8. If you have an older version of Universal Control that came out prior to the release of FaderPort 8, it won't recognize it. Make sure to register your FaderPort 8 in your https://my.presonsu.com account and get the latest download there or from the FaderPort 8 downloads section on the website.
0 votes
answered Sep 11 by pauldecesare (3,350 points)
edited Sep 11 by pauldecesare

You're not going to like this answer, but I had that same issue with my FaderPort 8 on the old firmware when it arrived last month, and two years ago when I plugged in my Studio 192 Mobile with old firmware... in BOTH instances i was using the cheap supplied USB cable from PreSonus. The way I got the 192 to be recognized and connect was using a $40 digital USB cable, the ones that people say are snake oil. In almost 2 years my 192 has NEVER failed to spin right up now on this cable, and it's just on USB 2.0, not even 3.0 which isn't even necessary. Soooo, the FaderPort 8 shows up last month, and guess what... I could get it to connect in Windows 10, but it would hang when trying to actuallyt run it, and it wouldn't show up in UC. Frustrating. So I unplugged the digital cable from the 192 and tried that on the FaderPort 8, and I think you can guess what happened: FaderPort showed right up in UC, and the firmware update went off without a hitch. I now own 3 of these cables, one for the 192, one for FaderPort 8 and one for my M-Audio CODE61 (black) controller. Google how many people struggle with the CODE series keyboards... locking up, needing rebooting. I had the 49 then sold it for the 61, and neither keyboard has locked up, not ONCE, using the digital cables. I know... this is a weird answer, but the $120 I spent on three lousy USB cables has turned my home studio experience into a joy, at least hardware wise. Those cables don't do anything for consumer peripherals, but for a clean path for a ton of data in music production, they work. Funny thing is, the $40 version is the lower end! They make digital USB cables that cost about $80 and $120! The $40 one is perfecto for a digital music studio.

...