Questions & Answers

I cant registred my studio 24

+1 vote
asked Mar 30, 2019 in Studio Series USB Interfaces by oorlidhi (140 points)

Serial number is invalid. Please verify your input.

Help me please! The number is entered correctly, many times checked. 

5 Answers

+1 vote
answered Mar 30, 2019 by chrisburl (230 points)
Looking at the support section, I'd say someone deleted the s/n database, as I and several others are having the exact same problem.

It's a bit ****, as I bought a brand new Atom today and without the S/N and registration, it's just an ornament! Can't download software or use it for anything.
0 votes
answered Mar 30, 2019 by shawnleenerts (320 points)
This is BS! I'm having the same issue! Was needing to use my new device this weekend for recording, but can't do squat because it won't register and there's no support on the weekend!
+1 vote
answered Mar 30, 2019 by johndavis52 (180 points)
I'm having the same problem -- Can't register my 24c Interface to get free Studio One Artist.  I see MANY others are having the same issue, so I suspect their SN server is down or something.  My temporary solution is to download the 30 day demo version...
+1 vote
answered Mar 30, 2019 by DaveHarryman (170 points)
Having the same issue with a Studio 1810 since last night. Thought all these questions on here were just popping up because that's what I searched for, didn't realize they were all from today. This is craziness. I assume, like me, a lot of you can't get to setting this stuff up during the week, and were looking forward to getting it all working for some recording on a Saturday. And no support for a silly situation completely out of our control, and probably easily rectifiable if someone was working over the weekend to maintain the serial number validation system. We can't all be mistyping numbers or letters.
0 votes
answered Mar 31, 2019 by davidbrookes (200 points)
edited Mar 31, 2019 by davidbrookes

Same probelm here, my nice shiny Studio 24c would be just be an ornament if I didnt use Cockos Reaper already which seems to have picked it up (but not tried yet).. Was going to give Studion One a try but the omens aren't good.  indecision

Tried again this morning and it registered!