Questions & Answers

Studio One 4.5 not starting

0 votes
155 views
asked Jul 9 in Studio One 4 by andreastarnaris (120 points)
edited Jul 9 by andreastarnaris
I have been using S1 4.5 Professional edition on Windows 10 X64 without a problem for a month now. Yesterday, having been working on a track, I opened a browser (Chrome) to watch a video tutorial on Youtube. Midway when I tried to go back to S1 I did not see it there. I do not remember me closing the program inadvertently.

I restarted it and it did not open when it reached the Starting MIDI Engine on the loading page. After many attempts and a couple of PC reboots I finally restarted it.

Repeated the Chrome routine again and the program shut down once again spontaneously. Same process was repeated until I finally reopened S1 and worked on it.

This morning again S1 does not start shutting down at the Starting MIDI Engine part; the same exact point. I do not get any error logs, so any help would be much appreciated.

1 Answer

+1 vote
answered Jul 10 by chrissederqvist1 (1,850 points)
That sounds like a really strange problem!

I've had occasional hiccups with S1 at that point in the startup process, hanging on "MIDI engine reset requested" or some message similar to that.

I'm on a Mac myself, but what I've done to fix this is to remove the application support files ending in .settings from my user account's ~/Library/Application Support/PreSonus Software/Studio One 4 folder on a Mac, but I think these files reside in:

C:\Users<username>\AppData\Roaming\PreSonus\Studio One 4 on Windows. Try deleting the "x64" folder from there and restart S1.

If that doesn't work I've gone on deleting the remoteservice.settings file and other files and tried starting the application repeatedly until it works... No silver bullet, but might do the trick.

These files store files regarding your user preferences, so they will be re-generated when you start the application if they're missing.

Some preferences must be set up again if you've changed the defaults.
...