Questions & Answers

How come I cannot download my "Trophies" bundle that came with my 26c???

+3 votes
asked Nov 15, 2019 in Studio Series USB Interfaces by alexanderlindblad1 (180 points)
I recently bought a Presonus Studio 26c.  With my purchase there was a "magic bundle" included such as lexicon verb, different tubes, gates and "trophies".

I went to the download page for my presonus. Copied the serial number for the plugin "trophies", and then pressed download.

After pressing the download button a page named "cannot find page 404" is displayed.    Im so frustrated. Why Is that so that I cannot download???   Cheers / Alex (Sweden)

5 Answers

0 votes
answered Aug 3, 2020 by AlexTinsley (924,900 points)
Best answer

As of August 2020, the StudioLinked "Trophies" plug-in has been removed from the Studio Magic Plug-in Suite and it is no longer possible to register that plug-in using the code provided by PreSonus.  

The Studio Magic Plug-in Suite is subject to change at any time.  

Thank you for your patience.

+1 vote
answered Nov 18, 2019 by vitalymatsevich (250 points)
Same here. I didn't get confirmation e-mail and the download link is just broken...
+1 vote
answered Nov 21, 2019 by davidarch (530 points)
Same issue here, StudioLinked has not responded to any emails, if anyone has info has to what is going on would be appreciated.
+1 vote
answered May 4, 2020 by jerarensberger (220 points)
Six months later... still no answer...

Actually I just bought an AudioBox a couple weeks ago and also received a Studio Magic Plugins Bundle. Trophies was included. When I registered the product I received an error message that said "an error occurred" and the page refreshed. Then I tried again, and received the message saying something like "Username or email already exist, please user another one." So I tried again using a different username and email and received a message saying something like "Username or email dose not exist, please use another one."

So I tried logging in using the first username and email, since the error message said it was already registered to that account. I will let me login, but there are no products on my download page. You would think it would be there if it were registered to that account.

I never received a confirmation email for that account either. I've checked both my inbox and spam. I have contacted Studio Linked 3 times in the past 2 weeks but I have got no response from them.
+1 vote
answered Jul 21, 2020 by arungpg (220 points)
I have been encountering the same too. And, it's a surprise that the problem has been persisting over 8 months..!

While the installation of other plug-ins was hassle-free, this one has been troubling me for the past about 24 hours.

 Initially, I thought I missed out something. But, later realized that the installation is not happening as shown in the installation instruction given.

 Presonus guys, can you please help fix it up? Thanks..!