Questions & Answers

Why am I getting "Skipping" and "Pops" recording directly into Audition?

0 votes
381 views
asked Jan 26 in Computer Based Recording & Production by jakelloyd (150 points)

This has been very frustrating and I'm hoping someone can help - I've used a presonus interface with Adobe Audition for years and in the past year or so, every so often while recording, sound will appear to "skip and pop" (example: https://www.dropbox.com/s/d0tprhg9k2d52im/audition_error_01.mp3?dl=0 ) in recordings. It has nothing to do with playback or rendering, its immediately in the raw recorded audio though its not noticeable enough in the wavelength to catch it happening in the moment because the pops are so quick and subtle - in fact you can only REALLY see it in the spectral frequency display. (shown here) It will come and go on its own and I can't recreate it on demand. audition_error_01.jpg

At first I thought it was just my old laptop - so I got a new laptop!. Turns out new laptop didn't have usb ports compatable with my red Pre-Sonus USB 2x2 - so I bought a brand new Presonus Studio 24c - and the problem persists.

I always run the most recent updated Audition, I have an HP 15 Notebook with an Intel Core i7-8565U and 32GB of ram, and the Presonus Studio 24c previously mentioned.

Does anyone have any idea why this is happening? Could it be sample rate? Bit depth? If anyone has any idea how I can prevent this or what may be causing it, I'd be endlessly grateful!

1 Answer

0 votes
answered Mar 13 by AlexTinsley (902,400 points)
 
Best answer

Your CPU is throttling as the demand for audio processing is causing the CPU speed to speed up and slow down

Looking at the specs for your laptop, the CPU will throttle between 1.16GHz up to 4.60 GHz. 

There are a few things you'll need to do to optimize your system for real-time audio. 

In your Windows Control Panel adjust power settings to "High Performance".

Intel CPU's have a nifty power saving feature called C-States (Core States) which will put cores on the CPU to sleep when not in use (even if it's for a few micro-seconds), when these cores sleep or wake up will cause problems with audio drop-outs or glitches in your audio. 

Restart your machine and enter your System Setup (ie BIOS), under CPU options disable C-States. Consumer grade HP laptop's unfortunately are a bit limited in what you can alter in the BIOS. You may need to find a software utility that will let you do this. 

On the Dell XPS13 we have in the lab we were able to disable this setting, showing this as an example: 

dell_xps_13_bios_cstates

There's another setting for SpeedStep which will disable the throttling of your CPU and run it at a single constant speed. However if the base speed of the CPU is low (ie 1.5GHz) then that's what the system will run at all the time, however your CPU won't cause drop outs as the processor speed ramps up and ramps down as load changes. 

The reason this all happens is power conservation. Windows system by default are not made for real-time audio and must be altered / customized / tweaked to make them work with ASIO applications. 

...