Questions & Answers

Quantum 2626 interface solid red light and not syncing to my PC

0 votes
384 views
asked Feb 17 in Thunderbolt - Quantum by zealousrecording (160 points)
I own a Sweetwater Creation Station 450 CS PC computer.  I use Cubase 9.5.  I recently installed an Asus ThunderboltEX 3 pcie card.  Connected my header and displayport connecting cable.  My new Presonus Quantum 2626 is plugged in via Thunderbolt 3 cable (Belkin 2.6").  The Presonus interface is not responding or syncing and has a solid red light.  Any information would be greatly helpful and appreciated.  Tried some different things but nothing is working. No recognization of the interface at all.

5 Answers

0 votes
answered Feb 20 by lloydwheat (140 points)
Mine is a blinking blue on the TB indicator and my system does not see it in preferences-> sound. I've re-installed everything more than once and still no dice. I gave permission in security settings for both apple and other developers to download stuff on to my system, no dice. Any help would be greatly appreciated.
0 votes
answered Feb 20 by katherineharris (180 points)
I have a similar problem with the Q2626 on a Mac install. I have an open ticket in Presonus Support over the situation. Not only that but upon registering the hardware, the Presonus system failed to authorize downloading rights to the software that’s supposed to be included with the unit, pretty frustrating to be sure!

Elsewhere on the site, I downloaded and installed Universal Control and the free version of Studio One 4. Both installs went fine. Like lloydwheat said, permissions in my Mac are good. I too have the flashing blue light on the Q. I can even see the driver (quantum_driver.kext) in Catalina’s extensions folder. Still, the Quantum doesn’t show up anywhere as an option, not in Mac System Preferences (Sound), nor in Studio One, Logic, or GarageBand.

Presonus tech support just asked me to upload a total system report off my Mac. Looks like some new code is going to have to be written? It’s a patience-testing process. Currently, interaction on my open ticket seems to be running a little over 24 hours on replies.
0 votes
answered Feb 21 by zealousrecording (160 points)
I figured it out.  It was dumb on my part because sweetwater had the step by step instructions.  I own one of their creation station 450’s (PC) and had to buy the asus thunderbolt ex3 card for it.  I happened to install it in the wrong slot.  Moved it to the furthest pcie slot next the the tb header and it went to work after a few bios adjustments.  I am unsure about the apple setup for this so i cant give any advice.  Wish i could
0 votes
answered Feb 21 by katherineharris (180 points)

I heard back from tech support and was directed to this article: https://support.presonus.com/hc/en-us/articles/115005456483-Installation-Issues-with-Universal-Control-on-High-Sierra-Mac-OSX-10-13?source=search

I'm running Mac OS Catalina, and even though the article is about High Sierra, the process works on the newest OS.

I followed the article procedures as described. The Quantum 2626 is now good. Universal Control now has access to the interface. Mac’s system preferences allow the device to be selected under “sound,” and the 2626 is now an option in all DAWs. The formerly flashing blue light on the Q2626 now solid blue.

I know "zelousrecording" started this thread about their PC. Apologies. Didn't mean to hijack this thread. However, if Window's security is throwing up a roadblock, it might be that Presonus' Knowledge Base (KB) has instructions that will resolve the issue filed under an older version of the Windows OS. That was the case here for the Mac OS--would not have thought to search the KB for High Sierra issues and solutions.

0 votes
answered Apr 23 by clarkspence (140 points)
When I set mine up today the thunderbolt light was red when it wasn't receiving signal. (before i had it plugged in). Then when I plugged it in it was blinking blue until I downloaded the drivers from presonus.  Once those were installed, it stayed solid blue.  Hope this helps..

-Clark
...