Questions & Answers

closed Why doesn't Universal Control v3.2.0.56558 let me pick 96khz even though all devices are disabled?

+1 vote
40 views
asked Mar 28 in AudioBox VSL Series by donnyvelazquez (180 points)
closed May 11 by donnyvelazquez
I have a Audiobox 1818VSL and I'm using the newest Universal Control v3.2.0.56558. When I installed UC and connected device it said device firmware needed upgrading. So I upgraded the firmware to v1.49. I restarted my PC and UC picked up my device right away. Then tried to change sample rate to 96khz and it won't let me pick anything over 48khz. I read the one post that said that anything using sound devices on Windows should be disabled. So I disabled every device except for Audiobox. Restarted and it still doesn't let me pick 96hz.

I don't know what to do next. This device worked great before. I love it because it works so seamless with Studio One. Please help!

System specs:

Windows 10 v1909 Build 18363.720
User Control v3.2.0.56558 Win x64
Audiobox 1818 VSL firmware: v1.49
Studio One Artist v3.5.6.46910 Win x64
Laptop MSI Stealth
closed with the note: PreSonus Team fixed issue with Universal Control.

1 Answer

0 votes
answered May 11 by donnyvelazquez (180 points)

Looks like the newest version of Universal Control has fixed this.

Thanks PreSonus Team

...