Questions & Answers

MPE support for VST3 instruments.

+47 votes
364 views
asked Jul 15 in Instruments and Plug-Ins by andrewgirgen (450 points)
With Studio One 5 release came MPE support but unfortunately it does not work with VST3 instruments.  Please fix this!

5 Answers

+19 votes
answered Aug 29 by douglaswinning1 (730 points)
selected Aug 30 by andrewgirgen
 
Best answer
I hope this feature gets supported soon! I just got a Roli Seaboard Block 25 key keyboard hoping to be able to work with it inside Studio One 5. The VST that the Seaboard comes with called Roli Studio Player will only run as a VST3 inside Studio One 5. So unfortunately it will sound glitchy whenever you press two notes at once in the current version.
Please upvote this request everyone!
+5 votes
answered Jul 21 by AlexTinsley (907,080 points)

Thank you for the feature request. 

If anyone else agrees or disagrees, please VOTE!

The developers pay close attention to those that are voted on the most. 

You are allowed one vote. You can change your vote later if you choose.

(Here's some helpful info on how to use the voting system)

Please vote the original question / feature request. 

Please DO NOT Vote on THIS response!

+3 votes
answered Oct 8 by arndkaiser (1,730 points)
Equator (by ROLI) runs as VST2 and VST3 inside Studio One. Unfortunately, the most recent ROLI installer hides the installed VST2 version. In order to fix this, you need to remove the VST3 dll manually from the VST3 plug-ins folder. This will make the VST2 re-appear in Studio One next time you launch. Hope this helps.
+9 votes
answered Nov 21 by GeorgTomitsch (1,430 points)
Yes, please fix this as soon as possible! The workaround below might help with Equator and Roli Studio, but the recently released Equator 2 no longer comes with a VST2 version.
–1 vote
answered Nov 25 by douglaswinning1 (730 points)

@arndkaiser Thank you for mentioning this. I did some digging and found it is similar with ROLI Studio Player. You have to trick Studio One 5 into not recognizing the VST3 version, and only use the VST2 file.

Navigate to C:\Program Files\Common Files\VST3
The file "ROLI Studio Player.vst3" can either be deleted, or renamed ROLI Studio Player.broken, something like that. This forces the software to not recognize it.

Then, the VST2 version is stored in C:\Program Files\Common Files\Steinberg\VST2

So you have to add this as a plugin location within Studio One.
You'll know it works if it says "Category: VST2" in the bottom right corner.
Also be sure to enable MPE for your device, as well as enable MPE in the vst window.
Hope this helps for the time being until VST3 is implemented :)

You need to make sure the Category is VST2

...